Showing results for 
Search instead for 
Did you mean: 

GetSettledBatchList Request returns No records found for date ranges

Hello, I am new to development and I am trying to get a list of settled batches from the TransactionAPI.


When I run GetSettledBatchList for a date range (ex: 2014-10-01T00:00:00 to 2014-10-15T00:00:00) that I know have settled batches against the production server, I get the following response:

<?xml version="1.0" encoding="utf-16"?>
<GetTransactionListResponseType xmlns:xsd="" xmlns:xsi="">
    <resultCode xmlns="">Ok</resultCode>
    <messages xmlns="">
             <text>No records found.</text>


When I run the same date range against the sandbox server with my sandbox API and transaction key, I get the expected list of settled batches which I placed in the system a few days earlier so they would settle.


Additional Info for production system:

  • AuthenticateTest returns valid login so I believe I have the right API login id and transaction key.
  • If I select a date range more than 30 days, I get the appropriate error message, I thought perhaps I wasn't sending the dates in correct format.
  • I took the batch id from the 10/14 settled batch and ran GetTransactionList for that batch id, same result as above: no records found.
  • I have confirmed that the Transaction details is enabled.


Am I missing a setting? or does anyone have ideas how to troubleshoot this further?





The API tester use XML.

Is not identical XML doesn't have the <request></request>

Since you know the transaction details API works for your sandbox account. Try the soap call to the sandbox account.

thanks.. sorry to waste everyones time, but i found the problem:


I had a suspicion that I had been given the wrong API login/transaction key, so I asked the group who sent it to me to verify.. sure enough, the key they had given me was from a very old account that was no longer being used but still active.


got the new ID/key combo and it works perfectly.. thanks for all your help!