Showing results for 
Search instead for 
Did you mean: 

rails direct post gem not working

I'm using the rails direct post gem for a test transaction, and I can't seem to get it working. There are a few problems:


- First of all, step 2 says to run the following:


sudo gem install authorize-net-1.0.0.gem


When downloaded, the version is 1.1.1, not 1.0.0. Not a big deal, just wanted to raise it. I just moved the file into my ~/vendor folder and ran:


sudo gem install vendor/authorize-net-1.1.1.gem


- Everything seemed to run fine from there, until I tried to start my server. When I ran script/server, I got the following error:



Missing these required gems:
You're running:
  ruby at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  rubygems 1.3.5 at /Users/Jake/.gem/ruby/1.8, /Library/Ruby/Gems/1.8, /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8
Run `rake gems:install` to install the missing gems.


Missing these required gems:  authorize-net  
You're running:  ruby at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby  rubygems 1.3.5 at /Users/Jake/.gem/ruby/1.8, /Library/Ruby/Gems/1.8, /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8
Run `rake gems:install` to install the missing gems.

I ran rake gems:install and tried to start the server again, but got the same error. Commenting out the config gem line in environment.rb allows me to start the server, but I get the following error when navigating to http://localhost:3000/payments/payment:



MissingSourceFile in PaymentsController#payment

Missing helper file helpers/authorize_net_helper.rb



What am I doing wrong?