cancel
Showing results for 
Search instead for 
Did you mean: 

relay response problems

Hello all. We are encountering a problem with the "relay response" of a SIM transaction. (We are aware that SIM is deprecated and are planning a new integration, but in the meantime we need this to function.)

 

Our logs show that we were receiving relay responses as of Tuesday, and we have not changed our configuration or code since then.

 

Even though the charge shows up as successful in our transaction log, we no longer see any connection in our server log, not even a 4xx or 5xx error.

 

A check with iptables verifies that we are not filtering anything in the 198.241 range.


As suggested at https://support.authorize.net/s/article/Why-Are-My-SIM-Relay-Response-Transactions-Timing-out-After-..., I setup a Requestbin and set our relay repsonse to that in a test script; the Requestbin also did not get posted to.

 

I also tried directing our relay response to a test script on a different server, and *did* receive the expected relay reponse POST from 198.241.206.38.

 

So this suggests that relay responses are failing to some IP addresses (our server and the Pastebin server) but not to others.

 

Is anyone else seeing similar behavior?

TomSwiss
Member
5 REPLIES 5


@TomSwiss wrote:

Hello all. We are encountering a problem with the "relay response" of a SIM transaction. (We are aware that SIM is deprecated and are planning a new integration, but in the meantime we need this to function.)

 

Our logs show that we were receiving relay responses as of Tuesday, and we have not changed our configuration or code since then.

 

Even though the charge shows up as successful in our transaction log, we no longer see any connection in our server log, not even a 4xx or 5xx error.

 

A check with iptables verifies that we are not filtering anything in the 198.241 range.


As suggested at https://support.authorize.net/s/article/Why-Are-My-SIM-Relay-Response-Transactions-Timing-out-After-..., I setup a Requestbin and set our relay repsonse to that in a test script; the Requestbin also did not get posted to about.

 

I also tried directing our relay response to a test script on a different server, and *did* receive the expected relay reponse POST from 198.241.206.38.

 

So this suggests that relay responses are failing to some IP addresses (our server and the Pastebin server) but not to others.

 

Is anyone else seeing similar behavior?


Yes I am. Did you now resolve this?

witu
Member

Unfortunately the only resolutuion I found was to hack up a workaround using the new API to retreive the transaction data. Fun way to spend my weekend, working around them sudddenly dropping vital functionality.

 

We opened a support ticket and were given the brush-off.

 
Extremely disappointed with AuthNet's lack of support here. 

Hi,

I myself a developer and recently created a website about some service that provide answers to help game fans. I need your suggestion there if you like to guide i'll appreciate. The website is https://dailyjumbleanswer.com . You should check and let me know about all the problems and mistakes If i am making any.

Thanks.

Emilie12
Member

Yeah, they have abandoned this forum I guess. But you can always check this https://www.on-magazine.co.uk/stuff/tech/top-5-automated-help-desk-software-to-boost-agents-performa...t ofind out the best automated help desk software. It will solve all your needs.

Hi Guys, let me help all jobless with service of professional cv writers. Make sure that your resume will be selected, follow https://www.cvuniverse.co.uk/. Modern resume is the first step in searching your favourite job. Hope to be helpful! Thanks)

slimus
Member