Showing results for 
Search instead for 
Did you mean: 

SIM is not working on HTTPS while working fine on HTTP on the same domain

SIM is not working on HTTPS while working fine on HTTP on the same domain. 


I am getting below error message in email

Your script timed out while we were trying to post transaction results to it.Transaction ID: 0


I have debug my source code a lot as well as run sample script which is generating same error. Please help me to troubleshoot above problem since website is going to live very soon.



Mohammad Tabrez


But I am still waiting solution for my problem .




Have you try using curl to post to the https page?

I have also tried with sample code provided for sim but not working for https but working for http.




One of the thing that I remember from a while back that, they were blocking connection that have "blank" user-agents

I am experiencing similar results, although I am using DPM.  But, its not just me, it seems that this is a extremely common issue with seemingly no help from Authorize.Net.


What we need as developers is a difinitive way to determine if Authorize.NET has some issues with the SSL certificate we are using.  The one we are using is from GoDaddy, a large CA.


I have viewed all the troubleshooting pages and I have seen almost every post on here about the issue and all things I should have tried, I probably have.  Most of the posts are left with no answers.


  • I can access my https url I send in "x_relay_url" from a test site which performs a post
  • I do not have a configured Relay Respone URL on the account, so url should be what I send in "x_relay_url"
  • Authorize.NET does not post to my url.

Am I suppose to tell my client to keep buying SSL certificates until we find one that works?  Doesn't sound like the right solution.


At this point, I am rather frustrated.