Showing results for 
Search instead for 
Did you mean: 

where is ANMobilePaymentLib in autherize sdk

In my project i need to implement payment gateway so that i tried to implement through Authorize.Net iOS SDK .

By googling i have followed some steps as in below

1)Downloaded Authorize.Net iOS SDK from

2) Goto MyProject -> Targets -> Build Settings.

1.Header Search Paths :


Mark the Recursive checkbox as checked


Library Search Paths : $(SRCROOT)/anet_ios_sdk-1.1.1/ANMobilePaymentLib

Other Linker Flags : -lxml2

3) Imported SystemConfiguration.framework

4) Imported libxml2.2.dylib and libxml2dylib

3) Drag and drop the ANMobilePaymentLib.xcodeproj file from Authorize.Net SDK folder into Xcode under MyProject.

Error : (while compiling)

'MobileDeviceLoginRequest.h' file not found

// Here i can't access the header folder

4 ) So that i have tried to add the sdk into my project like a framework , then i got different error

Error : (while compiling)

ld: warning: directory not found for option '-L/Users/sathish/Documents/CompanyApps/TestApps/PaymentGateway/anet_ios_sdk-1.1.1/ANMobilePaymentLib'

// Here i can't find the ANMobilePaymentLib in Authorize.Net iOS SDK and where i can download LibANMobilePaymentLib.a

pls guide me to resolve this issue.


    MobileDeviceLoginRequest *mobileDeviceLoginRequest =
    [MobileDeviceLoginRequest mobileDeviceLoginRequest]; = @"";
    mobileDeviceLoginRequest.anetApiRequest.merchantAuthentication.password = @"";
    NSLog(@"UIDevice =%@",[[[UIDevice currentDevice] identifierForVendor] UUIDString]);
    mobileDeviceLoginRequest.anetApiRequest.merchantAuthentication.mobileDeviceId =
    [[[UIDevice currentDevice] identifierForVendor] UUIDString];
    AuthNet *an = [AuthNet getInstance];
    [an setDelegate:self];
    [an mobileDeviceLoginRequest: mobileDeviceLoginRequest];


Set your Library Search Paths with the path that contains the "Authorize.Net SDK" library. (ex. "$(SRCROOT)/ANMobilePaymentLib").


sound like you didn't change directory so it probably




Hi sathishskd,


There is no need to set path for the ANMobilePaymentLib folder. You can remove this from the header search paths completely. The SDK has required header and implementation files. That should be enough. I suggest that you remove path for the “ANMobilePaymentLib” under Library Search path which is found on general project settings.




Hi RaynorC1emen7

I have followed your idea but i get following error ,


ld: building for iOS Simulator, but linking against dylib built for MacOSX file '/Applications/' for architecture i386

clang: error: linker command failed with exit code 1 (use -v to see invocation)



The unit testing classes aren't required for the build, so go ahead and remove sentestingkit references and any other unit test class that is blocking your build.

Does anyone figure out how to get this SDK working?

I followed all the steps that there are on the web (starting with turning off ARC for all the .m files included in the library).

After figuring that out, I happen to have the same exact error in this post and I haven't found a way to get it working.

I'm also following this project: that I managed to get it working; however, when I want to replicate the solution, I just can't.

The working example doesn't get rid of the unit test and doesn't include sentestingkit, btw.

And yes, I have tried to delete those files but the error keep appearing.


Using: Xcode 5. Please, HELP!



ld: warning: directory not found for option '-L/Users/ernestobarron/Developer/Kinektr/iOS/Authorize.NetEBarron/Black011/anet_ios_sdk-1.1.1/ANMobilePaymentLib'

Undefined symbols for architecture i386:

  "_OBJC_CLASS_$_SenTestCase", referenced from:

      _OBJC_CLASS_$_AuthNetUnitTests in AuthNetUnitTests.o

  "_OBJC_METACLASS_$_SenTestCase", referenced from:

      _OBJC_METACLASS_$_AuthNetUnitTests in AuthNetUnitTests.o

  "_STComposeString", referenced from:

      -[AuthNetUnitTests doMobileRegistrationAndLoginToGetSessionToken] in AuthNetUnitTests.o

      -[AuthNetUnitTests doMobileRegistrationAndLoginToGetCPSessionToken] in AuthNetUnitTests.o

      -[AuthNetUnitTests testAuthNetSingletonCreationWithEnv] in AuthNetUnitTests.o

      -[AuthNetUnitTests testMobileDeviceRegistrationAndLoginRequest] in AuthNetUnitTests.o

      -[AuthNetUnitTests testMobileDeviceLoginRequest] in AuthNetUnitTests.o

      -[AuthNetUnitTests testSimpleAuthNetPurchase] in AuthNetUnitTests.o

      -[AuthNetUnitTests testCardPresentAuthNetPurchaseWithTrack1And2] in AuthNetUnitTests.o


ld: symbol(s) not found for architecture i386

clang: error: linker command failed with exit code 1 (use -v to see invocation)




This is the error that appear when getting rid of Unit Tests Folder:


clang: error: no such file or directory: '/Users/ernestobarron/Developer/Kinektr/iOS/Authorize.NetEBarron/Black011/anet_ios_sdk-1.1.1/AuthNetUnitTests.m'

clang: error: no input files

Command /Applications/ failed with exit code 1

Same problem

can any one provide the integration Sample App

Hi Team,


I have integrate the anet_ios_sdk-1.1.1 in a sample project , its work fine as given in example.


but when i integrate it into my Live app with same steps , getting clag Error and Dsymutil error.


How to fix this issue. 



(Sample App get from URL :


Have you tried using the latest iOS SDK from Authorize.Net?