Showing results for 
Search instead for 
Did you mean: 

Webhook Notifications – Not Working – Sandbox Account

We are using Sandbox account to test the webhook notifications so that the set up can be replicated into production

Endpoint URL for the webhook subscription  is an Azure Function with HTTP Trigger

Issue: We have created a webhook subscription successfully with the above URL as the listener. The webhook is configured for all the events under productid – payments.

We used the API to create the webhook subscription  and it got created successfully.

We processed payments through following API and got success response code and payments are shown under the transaction tab of the sandbox account. However, endpoint is not receiving any webhook notifications corresponding to the payments events.

Please note that we confirmed that the receiver end configurations are working fine by creating a webhook in a Git Hub Repository with the same Endpoint URL.

We made sure the receiver end configurations are correct by creating a webhook in GitHub with the same Endpoint URL and we are receiving the notifications. 

Moreover, we tried changing the Endpoint URL to a RequestBin endpoint but still no notifications are received.

Are we missing something here?


  1. Do webhook notifications work in sandbox accounts?
  2. Why the status of the webhook subscription changes to ‘Suspended’ after few minutes of making it ‘Active’ using the update webhook API . This happens even when there are no transactions happening in the sandbox account .

NB: We are testing the webhooks to make sure that the same set up could be replicated in the live environment  . We need to ensure that the solution works before trying it out in production



Hi there,

It seems like you are having issues with the webhook notifications from CyberSource in your Sandbox account. According to the CyberSource API documentation, webhooks should work in Sandbox accounts. As for the status change of the webhook subscription to "Suspended", this could be due to a number of reasons such as incorrect URL, firewall blocking, or invalid SSL certificate.I would recommend checking the following:

  • Make sure the Endpoint URL is correct and accessible
  • Check your firewall settings and ensure that the URL is not being blocked
  • Verify that the SSL certificate on the Endpoint URL is validYou can also try creating a webhook in a different environment, like a localhost, to rule out any issues with the receiver end configurations.If the issue still persists, I would suggest reaching out to CyberSource support for further assistance. They would be better equipped to help you resolve the issue with the latest apk

Webhook notifications should work in sandbox accounts just like they do in production accounts.

It is possible that there could be an issue with the configuration of the webhook or the endpoint URL.

Regarding the webhook subscription changing from 'Active' to 'Suspended', this could be due to a variety of reasons such as repeated delivery failures, endpoint returning a 4xx or 5xx HTTP status code, or the webhook subscription expiring.

It is important to review the webhook logs and error messages to determine the specific reason for the suspension.

Here are some suggestions to troubleshoot the issue:

  1. Verify that the webhook subscription is created and active in the CyberSource sandbox account.
  2. Check the logs on the Azure Function endpoint to ensure that the webhook notifications are not being blocked or filtered out.
  3. Ensure that the endpoint URL is correct and reachable from the internet.
  4. Verify that the webhook events are being triggered by performing test transactions on the sandbox account and checking the webhook logs for any activity.
  5. If the issue persists, consider reaching out to CyberSource support for further assistance.

It is important to resolve any issues with webbook notifications in the sandbox account before moving to

production to ensure a smooth transition and minimize any potential issues.