Showing results for 
Search instead for 
Did you mean: 

An error occurred while decrypting the EMV data when using iOS SDK

Hello I am trying to use Demo iOS app from this repository:

So far every transaction fails with error “An error occurred while decrypting the EMV data”.
I tried many different cards with the same result (all cards have the chip and are issued in US).
I am using ENV_TEST environment.


The response that comes back in the completion block of :

AnetEMVManager.sharedInstance().startEMV(with: aRequest, presenting: self, completionBlock: {
is nill and Error is “EMV Transaction Error” - code 2
What could be wrong?

Hey, are there any developers reading this? Woudl appreciate to get in touch with someone who could help me make some progress with. To add to my original post - I am testing with a device that was purchased from (it has NYWHERECOMMERCE label on it)


Has anyone been able to successfully implement the InPerson SDK for EMV on iOS with the AnywhereCommerce device. We tried back in April 2017 with both a Sandbox and Production version of the hardware without ever successfully processing an EMV transaction - neither in the demo app nor in our own app.


It looks like there may be some changes they’ve made (they implemented Quick Chip technology, which reduces the transaction time) that make it worth trying again.


But has anyone succeeded? Even brief anecdotal reports would be appreciated, in addition to any detail about how you made it work.

I am planning to work with my iOS dev to look into this issue on coming Tues.  BTW, We have Monday as company holiday. Thanks for your patience.



Authorize.Net Expert Authorize.Net Expert
Authorize.Net Expert



Is it a sandbox/PROD reader? please note that a PROD reader will only work with PROD account and SANDBOX will work with SANDBOX account? SDK/.APP allows you to switch between the environments?


Please let me the know the serial number of the reader, I will be able to tell if its a SANDBOX or not.


There is no way one reader can be used in both environments. 




Authorize.Net Developer Authorize.Net Developer
Authorize.Net Developer

Thanks Pankaj for quick turnaround upon asking!



Authorize.Net Expert Authorize.Net Expert
Authorize.Net Expert

We have two and neither worked for Sandbox or Prod. (We haven't tried them since April 2017 so that was with the inperson SDK before the July - Dec 2017 changes you put in there.)


One of our two has serial number stamped by the connector: 00001023150004


The other one doesn't have a serial number stamped on it. But it has a cardboard around the plastic case with 76379507020887, Version, Config Ver. 4.



Why am I getting this error when I swipe a credit card? As I understand it, Swiping the card doesn't involve the EMV hardware. (ENV_TEST with sandbox login)


If it does, I'm guessing not even the swipe data is going to get set to Chase Paymentech until they certify. Would that be the case?


Do you found the solution i am facing the same error with Windows SDK?

How can i figure it out which device type i do have ?