Showing results for 
Search instead for 
Did you mean: 

CIM: Using test mode to generate specific transaction results not working



I have tried to follow the guide lines in setting up a test account in sandbox for However, I am unable to still get an error code out of when i use the test zip code: 46205 or anything or cvv code. What am i doing wrong? I used both 4111111111111111 and 4007000000027 (sent to me in an email by Does the amount to be charged matter?


For that use 4222222222222 13digit


Unfortunately using 46282 as the zip code for response message of  "This transaction has been declined" and using 4222222222222 as the credit card number still makes the transaction proceed without being rejected. Its just not being rejected!

did you have testmode turn on, on the test account? turn it off.

Its in live mode not in test mode. This is what I see on that page:


This account is currently inLIVE MODE.

can you tell us how are you testing this with CIM?

Create the payment profile with zipcode 46205 or add x_zip to extraOptions?


I'm having the same problem and I'm going insane!

AuthorizeNet has like 3 different sources of information where the generation of erros is suppose to be done differently.


This is what I have.


- I'm running Rail and using ActiveMerchant gem to comunicate with AuthorizeNetCIM.


Here is an example of a successful transaction that its supposed to be declined.


========= ORDER INFORMATION =========

Invoice : 112

Description : Testing

Amount : 2.00 (USD)

Payment Method : Visa

Type : Authorization and Capture


============== RESULTS ==============

Response : This transaction has been approved.

Authorization Code : 000000

Transaction ID : 0

Address Verification : AVS Not Applicable



Customer ID : 270

First Name : Marjory

Last Name : Ratke

Company : 

Address : 62753 Gillian Expressway

City : Novastad

State/Province : AZ

Zip/Postal Code : 46282

Country : United States

Phone : 

Fax : 




This has every possible attribute to trigger the decline and is not doing it.



The test mode is OFF.

I'm hitting the test uri:

I'm sending the test flag for every response.


if test mode is off, there should be a transaction id.


I had the same problem but It turned out that the ActiveMerchant Gem was doing every request sending the x_test flag on if you set the gateway in test mode.


I added an option to hit the test_url but keep the real requests in order to get the generated errors.



Hope this helps.