Showing results for 
Search instead for 
Did you mean: 

Empty response when sending Authnet xml via Windows 8.1/IIS/PHP to ARBCreateSubscriptionRequest

I have Authnet PHP code that worked perfectly last time I ran it about 2 years ago on Win7 IIS7.5 PHP. Now I am trying to run it on Windows 8.1 and all I get back is an empty response, every time. Here's the test URL I'm sending to:


And here is my full XML that I'm sending:



<ARBCreateSubscriptionRequest xmlns= "AnetApi/xml/v1/schema/AnetApiSchema.xsd">
    <name>TransitPark Monthly Indoor</name>
        <address>1029 Sunset Ave.</address>

The name and transkey values have been changed for the post, but I verified they are valid sandbox api keys. Is there something wrong with my XML?


The source code is nothing special, it's straight out of Authnet sample code that I downloaded. Any idea what could be going wrong?


Accepted Solutions

One note, the response may not be literally empty, it's hard to tell. Looks like I might be getting this actually:


 error: Error:

Also don't worry about the expired cc expiration date. I just tried it with non-expired date and got exact same problem. Also tried different cc# from Authnet website.


Did you check for connection error since they change SSL not too long ago?

How do I check for connection problems? Authnet is not returning any info to me.

Hello @ZeroGravPro


We recently upgraded our security certificates to support SHA-2.  For PHP, you may need to obtain the .PEM file from the PHP SDK on GitHub.



Richard, is it just a matter of copying those files to my PC? Or do I need to do something in particular with the .pem file?

Richard: No PEM files exist in the github location you pointed me to:


Where can I get that file, and where in my SDK folder path to I place it?

Thanks Richard. Replacing the .pem file indeed fixed everything in my authnet sandbox environment.