Showing results for 
Search instead for 
Did you mean: 

GetSettledBatchList Request returns No records found for date ranges

Hello, I am new to development and I am trying to get a list of settled batches from the TransactionAPI.


When I run GetSettledBatchList for a date range (ex: 2014-10-01T00:00:00 to 2014-10-15T00:00:00) that I know have settled batches against the production server, I get the following response:

<?xml version="1.0" encoding="utf-16"?>
<GetTransactionListResponseType xmlns:xsd="" xmlns:xsi="">
    <resultCode xmlns="">Ok</resultCode>
    <messages xmlns="">
             <text>No records found.</text>


When I run the same date range against the sandbox server with my sandbox API and transaction key, I get the expected list of settled batches which I placed in the system a few days earlier so they would settle.


Additional Info for production system:

  • AuthenticateTest returns valid login so I believe I have the right API login id and transaction key.
  • If I select a date range more than 30 days, I get the appropriate error message, I thought perhaps I wasn't sending the dates in correct format.
  • I took the batch id from the 10/14 settled batch and ran GetTransactionList for that batch id, same result as above: no records found.
  • I have confirmed that the Transaction details is enabled.


Am I missing a setting? or does anyone have ideas how to troubleshoot this further?





You said GetSettledBatchList but the xml said GetSettledBatchList


Thank you!.. I had copied the wrong error  into the post.

Here is the one that was supposed to be there:

<soap:Envelope xmlns:soap="" xmlns:xsi="" xmlns:xsd="">
        <GetSettledBatchListResponse xmlns="">
                        <text>No records found.</text>

And you can find transactions with that batchID on the merchant account website?


can you post the request xml masked your loginID and tranKey?

yes,  That is where I got the batchid from, I opened a transaction from the detail report and copied/pasted the batch id listed under settlement information.


here is the request XML ( i am using SoapUI for initial testing)

<?xml version="1.0" encoding="utf-8"?>
<soap12:Envelope xmlns:xsi="" xmlns:xsd="" xmlns:soap12="">
        <GetSettledBatchList xmlns="">


below is the raw XML that SoapUI shows:

Accept-Encoding: gzip,deflate
Content-Type: application/soap+xml;charset=UTF-8;action=""
Content-Length: 738
Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.1.1 (java 1.5)


I wonder if it an issue with how they handled the soap.

The didn't show the <request></request> node. and the xml don't have them either.

You might consider trying this in the API Reference console:



Thank you, I tried using it and for sandbox it worked perfectly, when I plugged in the production API Login and key it replied with invalid authentication ( I suspected it would fail as the dev credentials worked, but thought I would try it anyways).


is there a production system version of this API reference console?



The API Reference console only works with the sandbox.  Were you able to successfully use your original request posted in the thread in the console, or did you need to modify it  to work?



No, the API tester would not accept a SOAP request. The page does have a link which shows a sample.. I compared that to what I had submitted, it is identical except for the values that I had to put in.


Are there any differences between production and sandbox (other than the login id and transaction key)? My request works fine agains the sandbox, but when i run the same against production I always get no records found