cancel
Showing results for 
Search instead for 
Did you mean: 

How to integrate to Android app using JDK 11.

Hello everyone,

thanks for helping beforehand.

I want to integrate Authorize.net into my Android app, however, the java SDK only supports JDK 1.8 while mine is 11. And I use PHP as my backend server. 

I found Accept Mobile SDK, but it only gets me a token standing for the credit card data. Is that safe that I pass the token to my server and use PHP SDK to deal with the payment process from the token? 

And the Accept Mobile SDK seems not to require the billing address, do I also need to pass the billing address to my server? Is that also not safe for the customer info?

natsume123
Member
5 REPLIES 5

I am using the latest Android Studio Arctic Fox 2020.03.01 Canary 8 and AGP 7, and I want to convert my project to use Java 11. Apparently just doing the following does not work as mentioned on https://developer.android.com/studio/preview/features#use-java-11:

Gislason
Member

@natsume123 ReadyPay Online wrote:

Hello everyone,

thanks for helping beforehand.

I want to integrate Authorize.net into my Android app, however, the java SDK only supports JDK 1.8 while mine is 11. And I use PHP as my backend server. 

I found Accept Mobile SDK, but it only gets me a token standing for the credit card data. Is that safe that I pass the token to my server and use PHP SDK to deal with the payment process from the token? 

And the Accept Mobile SDK seems not to require the billing address, do I also need to pass the billing address to my server? Is that also not safe for the customer info?


This is my first time on the site - really happy to find this support group. I have personally struggled with internet addiction issues and look forward to exploring the resources here.

Bailey
Contributor
I see, thanks. I’m currently using Accept Mobile SDK and try to use PHP api for payment…. Hope this can work.

@Gislason wrote:

I am using the latest Android Studio Arctic Fox 2020.03.01 Canary 8 and AGP 7, and I want to convert my project to use Java 11. Apparently just doing the following does not work as mentioned on https://developer.android.com/studio/preview/features#use-java-11:my wake health


But still faced this situation ..

I have same question, kindly help me out.