cancel
Showing results for 
Search instead for 
Did you mean: 

NULL RESPONSE returned from Java SDK call

My web app is in Java and deployed to Linux server, When I tested Credit Card payment, I always got "null response" from authorize.net.

The problem is, if I ran the app on my PC (windows), the payment was successfully processed. Then I ran a curl command as below on two environments -- Linux and windows

         curl  -v  https://api.authorize.net/xml/v1/request.api

The difference is the order of the following two lines. On Linux, the order is #1, #2. On windows, the order is #2, #1.

1. Connection #0 to host api2.authorize.net left intact
2. {"messages":{"resultCode":"Error","message":[{"code":"E00001","text":"Error reading JToken from JsonReader. Path '', line 0, position 0."}]}}

On Linux, null response is always returned. But on windows, the transaction works. Any idea?

alphenix
Member
2 REPLIES 2


@alphenix wrote:

My web app is in Java and deployed to Linux server, When I tested Credit Card payment, I always got "null response" from authorize.net.

The problem is, if I ran the app on my PC (windows), the payment was successfully processed. Then I ran a curl command as below on two environments -- Linux and windows

         curl  -v  https://api.authorize.net/xml/v1/request.api

 

The difference is the order of the following two lines. On Linux, the order is #1, #2. On windows, the order is #2, #1.

1. Connection #0 to host api2.authorize.net left intact
2. {"messages":{"resultCode":"Error","message":[{"code":"E00001","text":"Error reading JToken from JsonReader. Path '', line 0, position 0."}]}}

On Linux, null response is always returned. But on windows, the transaction works. Any idea?


Thankful for the little by little useful exercise. Has conclusively the ordinary impact.

Duncan
New Member


@Duncan wrote:

@alphenix wrote: 

My web app is in Java and deployed to Linux server, When I tested Credit Card payment, I always got "null response" from authorize.net.

The problem is, if I ran the app on my PC (windows), the payment was successfully processed. Then I ran a curl command as below on two environments -- Linux and windows

         curl  -v  https://api.authorize.net/xml/v1/request.api

 

The difference is the order of the following two lines. On Linux, the order is #1, #2. On windows, the order is #2, #1.

1. Connection #0 to host api2.authorize.net left intact
2. {"messages":{"resultCode":"Error","message":[{"code":"E00001","text":"Error reading JToken from JsonReader. Path '', line 0, position 0."}]}}

On Linux, null response is always returned. But on windows, the transaction works. Any idea?


Thankful for the little by little useful exercise. Has conclusively the ordinary impact.


I am trying to read an API response using a GET request. The URL is a string that is created in another class and is passed. I have validated that the URLs that are being created are valid and working but my return value is null. The odd thing about this is that it works once correctly when I make another call, but every other time it's called after the first, it only returns null.