Showing results for 
Search instead for 
Did you mean: 

No response after Submission AIM php sdk - changed nothing


My store has been working for about two years.

A few days ago when a user submits their Card info.

I get NO Response from authnet, and the submit page refreshes (times out?)

I've changed nothing and don't know where to look. 

Have been at it most of the day and can't seem to get it going.

Any suggestions would be greatly appreciated.


Thank you


Hello @Coffee1HouseDEV


Please see this thread about updating your cert.pem file if you have not updated your PHP SDK since May 2015.



Administrator Administrator

I copied the new one over, and still get the same thing....

No response from the server.

Thank you for your quick response.

Anything else that I might try?

new Cert.pem file.

That did the trick thank you!!!!!!

This is now a problem again. Same thing as before.

But I uploaded the new cert.pem file, but this time it did not fix the problem.

After the user submits the credit card for payment,

the page refreshes with this text appended to the url:



You need to update your POST url. Find the php file that has your post URL and make sure you pdate it. So instead of posting to: try posting to: instead.

This worked for me which is the same issue you are having. Mine post url was in the lib folder called AuthorizeNetAIM.php

this is how it should be done.