Showing results for 
Search instead for 
Did you mean: 

Opencart 3.0 SIM module not processing correctly

I'm using the latest version of OpenCart and the SIM module but the process is failing when the response returns to Opencart. The process partially completes but ultimately doesn't. System seemed to be working back in december (12/2017) but in January 2018 the following is happening. The specifics:


1. Running OpenCart and SIM module

2. When checking out, the shopper is taken to's sim page to complete their payment information. 

3. Once completed, the transaction appears complete, shopper is returned to the cart and cart appears to have emptied, the payment DOES process through.

4. If you click on the "Continue" button, the cart then has all contents retiurned to it (as if you had not checked out) and where the shopper should have received an invoice and "Thank you" nothing is mailed out.

5. When I log into the cart as admin, the order isn't visible but CAN be found by searching for "Missing Orders".

6. When the order status is manually reset from missing to processing, the order appears now with other orders AND the email to the shopper is sent thanking them for the order and confirming order contents and specifics.


What I've noticed:

1. I've tried numerous tests to see what is happening and could not trigger a complete order through opencart. A tech at suggested it must be a timeout thing, but that doesn't appear likely and my host has confirmed that time on my server is set accurately to the US nuclear clock. I had a PHP time stamp reset to Eastern Standard Time but that doesn't seem to have impacted the clock in the cart (based on error log) and didn't impact the checkout processes.


2. The relay response pages on admin do NOT match what relay response is set to in my cart in the sim module page. That field, however in opencart is not editable. I suspect that may be the issue but I do not know how to adjust that field so I can't test it. When I tried to reset the field in to match what is in OpenCart, failed to return me to the cart after checkout and produced an error code instead.


I have a lengthy item on the opencart forum trying to work through and figure out what is happening here but nothing seems to be getting the job done. Any ideas from this direction? -thank you.