Showing results for 
Search instead for 
Did you mean: 

Parse error: syntax error, unexpected T_CLASS in... AuthorizeNetRequest.php on line 8

EDIT:  /sigh -- that was easy.  I'll leave here in case someone else is in the same boat.


I was one...

echo "The current PHP version being used is: " . phpversion ();

... away from seeing:

"The current PHP version being used is: 4.4.9"


Req of 5.2 here:


In my case (1and1), you can create an .htaccess file in the site's root folder with the following line:

AddType x-mapp-php5 .php 





I've written a site that worked on my local box, then worked perfectly with a return page on my own business website.  But now that I've moved it to the client's server, it's busted.


I'm now testing with a file that only has this line in it:


<?php require_once 'anet_php_sdk/AuthorizeNet.php'; // Include the SDK you downloaded in Step 2 ?>
... and I still get... 
Parse error: syntax error, unexpected T_CLASS in /[path removed]/anet_php_sdk/lib/shared/AuthorizeNetRequest.php on line 8
I've tried messing with the file a bit to make sure the server's seeing it, adding lines, etc, and that's fine.  I've re-download, as suggested, even tried different versions.  Still get the error.

Is there a minimum php requirement or needed module I should be checking for?