Showing results for 
Search instead for 
Did you mean: 

Relay Response is not receiving POST from Authnet server

Hi Everyone,

I am using SIM. When a payor goes through the process of submitting card details on the hosted payment page, they see the following error:

An error occurred while trying to report this transaction to the merchant. An email has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card.

This transaction has been approved.

It is advisable for you to contact the merchant to verify that you will receive the product or service.

The payment does gets captured, we just don't receive the POST messages on our relay url.

Investigating it further, we realized that we have suddenly stopped receiving the relay-responses to our relay url from July 20th. In order to troubleshoot, contacted the support and they inform us that they are receiving the following error message while sending the POSTs to our relay-url.

The following URLs are failing with Wininet error code of 12019.
http:// -- url redacted .php
http:// -- url redacted .php
http:// -- url redacted .php
http:// -- url redacted .php

There are four of our urls which I have redacted.

I have investigated the error message further and it apearrs to be a bug listed by Microsoft. I am not sure if it has been fixed or perhaps the bug still persists in the servers even though it has been fixed by Microsoft. Here is the Bug article and another useful article. However, this is something Authnet has to implement, so I am not sure how to go about it. I need to be sure about this.

On our side, I have tried the following:

  1. Externally hosted (on Amazon Web Services) a sample app with same merchant credentails; the results are same - the process fails with the same error as above.
  2. We have a software vendor who is creating an app for using a different programming language ( They are hosting on a different server than current payment interface, though both of them are locally hosted, they are experiencing the same issue as well.
  3. I have tried HTTP post using a web form to a test relay page on our local Web Server where our payment interface is hosted. The posting web form is hosted on an Amazon server. It succesfully works and POST variables are being received.

Please share your thoughts about how we can fix this issue.


Many thanks





Full url is required because authnet is posting response to your server and relative urls will not work.


Also, you are required to specify the "full url of the file" that will be receiving the relay-responses, both in your code as well in the Merchant Panel. It is a sort of cross-verification by Authnet to ensure that only the urls listed in the merchant panel get the relay responses.


An example of a relay response URL will be:


I hope this helps.


Hi Kahuja,


Wow! That is insane! :smileylol: How can I add all my relay URL when it's all dynamic because it's an Event Registration payment.


Do you happen to work on this using Sandbox?


I actually work on the payment gateway code sandbox and using relative URL, everything works fine until I switch to live where I constantly getting that replay response error. engineer, anyone from you, please comment to this. I just need a clear answer on how to fix this issue.


Thank you!

It work on the sandbox? Did you have the relay response url setup on the sandbox account? are they the same as the production account settings?


Are your sandbox account test on the same server as the when you switch to live?


The other way is to ask the developer support to see what response are they getting when they post the response to your relay response url.

Hi Reynor,


Here's my setup. Sandbox has to be a different account from the Production Live Merchant Account, unless, I'm wrong understanding this. But I created an entirely new Sandbox Merchant account separate from our Production Merchant Account.


Sandbox Relay/Receipt URL

Live Relay/Receipt URL


Both installation are running on the same server by different Apache host name and all the settings are identical.


In Sandbox installation, I am not getting a Relay error and I am sure it relay back because whatever I echo out on the relay url gets printed in the scree.


On the other hand, on Live installation, I don't get any of my echoed text. It's like never even bothered to relay it and just spit an error.




So it running https? I remember having issue with some ssl cert. might need to search on the forum.


SNI not supported