Showing results for 
Search instead for 
Did you mean: 

Relay Response is not receiving POST from Authnet server

Hi Everyone,

I am using SIM. When a payor goes through the process of submitting card details on the hosted payment page, they see the following error:

An error occurred while trying to report this transaction to the merchant. An email has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card.

This transaction has been approved.

It is advisable for you to contact the merchant to verify that you will receive the product or service.

The payment does gets captured, we just don't receive the POST messages on our relay url.

Investigating it further, we realized that we have suddenly stopped receiving the relay-responses to our relay url from July 20th. In order to troubleshoot, contacted the support and they inform us that they are receiving the following error message while sending the POSTs to our relay-url.

The following URLs are failing with Wininet error code of 12019.
http:// -- url redacted .php
http:// -- url redacted .php
http:// -- url redacted .php
http:// -- url redacted .php

There are four of our urls which I have redacted.

I have investigated the error message further and it apearrs to be a bug listed by Microsoft. I am not sure if it has been fixed or perhaps the bug still persists in the servers even though it has been fixed by Microsoft. Here is the Bug article and another useful article. However, this is something Authnet has to implement, so I am not sure how to go about it. I need to be sure about this.

On our side, I have tried the following:

  1. Externally hosted (on Amazon Web Services) a sample app with same merchant credentails; the results are same - the process fails with the same error as above.
  2. We have a software vendor who is creating an app for using a different programming language ( They are hosting on a different server than current payment interface, though both of them are locally hosted, they are experiencing the same issue as well.
  3. I have tried HTTP post using a web form to a test relay page on our local Web Server where our payment interface is hosted. The posting web form is hosted on an Amazon server. It succesfully works and POST variables are being received.

Please share your thoughts about how we can fix this issue.


Many thanks



Hello @kahuja 


Without knowing the URL that the gateway is trying to POST to, it's difficult to troubleshoot further.  If you are uncomfortable posting the URL here, you can send a support request with the information to



Administrator Administrator

how much data are you responsing if the transaction is approve or decline?

I am only processing the following variables in the relay response page:



$ResponseReasonText = trim($_POST["x_response_reason_text"]);
$ResponseReasonCode = trim($_POST["x_response_reason_code"]);
$AVS = trim($_POST["x_avs_code"]);
$TransID = trim($_POST["x_trans_id"]);
$AuthCode = trim($_POST["x_auth_code"]);
$Amount = trim($_POST["x_amount"]);


//custom variables i need back
$token = trim($_POST["x_token"]);


Is there a way for me to get to the size of what is being sent to the relay response? There may be scope of getting rid of unwanted POST data; I only need the variables above.




For testing you can change the relay response url to

make sure you add it to the valid relay url list in your mechant account.




I have done it. Received the variables in the dump as expected. What is the purpose for this step you advised?



Hi Everyone,

We were able to identify the issue. Our firewall was blocking the relay reponses because it believes they contain a trojan. The malware belongs to the category Zeus (which is known for stealing financial information). 


We have sought clarification from our Firewall provider (Checkpoint) and at the same time, we invite thoughts and clarifications from the developer community and more importantly, as a company.


Please see the screenshot below:







Reposting the screenshot (previous one looks broken): 


Hi Raynor,


I am having the same issue as well on this, and it's making me crazy.


When you said:


For testing you can change the relay response url to

make sure you add it to the valid relay url list in your mechant account.


The Valid Relay URL that you're talking about, should be it be the complete URL? For example:


If full URL is required, then must be insane to require that. I am assuming, only:

 is required to be intered in Account Settings > Response/Receipt URLs. Am I understanding this right?


I am so frustrated after working on Sandbox for 3-4 months and when I switch to Live in our Live website I am consistently getting this error without much details as to where the error is coming from. I tried to echo "Hello World" in the x_relay_url just to see if I see it then I know is relaying back but I'm not seeing it. So where is the error?


Thank you!