cancel
Showing results for 
Search instead for 
Did you mean: 

Urgent !!! Suddenly Hosted Payment form behaving weird

Urgent !!! Suddenly Hosted Payment form behaving weird

Hi Team,

We are using authorize.net hosted payment form since long ago and it was working fine in both sandbox and production .

 

Today in sandbox account we observed hosted payment form suddenly started showing order summary at the top of the form and phone number as a mandatory field.
We never seen these before or we have not touched or made any changes in authorize.net implementation.


Also, in IE hosted payment form stop working. When user click on complete checkout button its got stuck on that hosted payment form only.

We have never seen this before with sandbox.

I am wondering why we are getting these things at this movement.

 

Have you released any changes in sandbox configuration/hosted form ?

Please let us know as this is blocker for our Testing and UAT.
As of today production is working fine but still can you please make sure that there is not changes released for production.


Thanks,
Ravi

raviparmar
Member
13 REPLIES 13

Hi @raviparmar

 

Thanks for the feedback . Yes we are fixing the below 2 issues for sandbox .  

 

Can you let us know what is the version of IE and operating system you seeing the issue ?

 

Thanks

 





Send feedback at developer_feedback@authorize.net
Anurag
Administrator Administrator
Administrator

Dear Anurag,

 
Thanks for your response.
 
Is there any ETA for this fix ? And when we will get this as it is in sandbox?
In IE when we click on Complete Checkout button from the iFrame its not moving ahead and stuck up.
 
 
We are not able to move it forward because of these issues so I can't comment about any other issues .
 
Can you please also make sure that this will not impact our production environment.
 
Thanks,
Ravi Parmar

Hi @raviparmar,

 

Fix is done from Dev side and currently it's going into our test environment.

 

According to our current plan, fix will be available in sandbox tomorrow morning.

 

We will definitely keep you posted as soon as sandbox deployment is done, so that you can verifty from your side.

 

Thanks again for your feedback!

 

 

- Angie

angie
Authorize.Net Developer Authorize.Net Developer
Authorize.Net Developer

Hi, @raviparmar,

 

Our new deployment to sandbox is done. Could you please verify from your side, see if the issues are fixed?

 

It would be helpful if you can clear your cache in the browser first and do the verification.

 

 

Thanks,

Angie

angie
Authorize.Net Developer Authorize.Net Developer
Authorize.Net Developer

We are noticing similiar issues.  We have noticed that the order summary has been removed.  However we have test automation around the accept hosted iframe and notice that the functionaility has changed.

 

In the past, if you entered an invalid card number, there was an error message displayed to hint to the user that their card number was invalid.  Now, there is no error, and the submit button is disabled.  Is this something that we can expect to be reverted to the old functionality?

Hi @jwh31579,

 

The card number validation is still there. Hint(red border line) should still show when card number is invalid.

 

Could you please clear browser cache and try again? If issue continues, attach a screenshot? That will be very helpful.

 

Thanks a lot!

 

- Angie

angie
Authorize.Net Developer Authorize.Net Developer
Authorize.Net Developer

Phone number is no longer a required field, so we can go ahead with some of our automated testing.  However, on IE, we still get all of the new fields.  When we press the button to submit the credit card information, it hangs in your code.Accept_Hosted.PNG

 

By corporate policy, the users who do the UAT testing are required to use IE.  So our UAT testing is still blocked.  We had hoped to complete our UAT testing today.  Please look into this as soon as possible.

Also country field is overlapping.

 

We are using IE11(with document mode 10) and Windows 7 & 8

 

Thanks

Hello, there used to be an error msg on the UI where declined card error message shows.  Below is an example of where the error msg would show up.  The error "Invalid Card Number" is no longer present on the UI, there is only the red underline that you mentioned.

 

AuthNetError.png

Hi ReadyQA, 

 

The card number in your example passes a Mod-10 check for a valid MasterCard BIN, so you should see a decline with a test card number as it should not be invalid. We recently updated our MasterCard BIN range. We are not sure when you last saw an invalid response, but this decline response in Production and a Success response in Sandbox. 

 

Can you confirm that you are seeing this with this card number and in what environment and provide any additional detail that may be helpful to us in understanding what you are encountering? 

 

Thank you,

Elaine