Showing results for 
Search instead for 
Did you mean: 

Webhook tests send wrong event

We've created webhooks for each of several types of events we want to track.


When we go to test them, no matter which webhook we test (e.g.


, the event that is sent is "net.authorize.payment.authcapture.created".


What is the point of a webhook test if it doesn't actually simulate the webhook?


I don't think its our domains issue, It was working perfectly yesterday on the same domain, Today stoppeed working and when testing it gives this error 
Error: The ping operation failed. This could be due to connectivity issues, invalid url or server downtime. Check the url details for the webhook and try again


> if you moved to a well established domain you wouldn’t have this problem. 


Or if we moved to a payment gateway that could be bothered to invest in DNS infrastructure that any startup in 2019 has, we wouldn't have this problem.


I get that if you've made the investment in, you're willing to put up with this sort of thing because you're already on board. You're hardly going to scrap your existing investment just because of a DNS issue on a sandbox. But imagine that that's your first ineraction with, and the 'legacy' provider you're moving off of never had any problems like that. How do you suppose it looks to us engineers, much less our customers?


It miraculously started working tonight, so it likely was DNS. Nothing like a black box with no detailed errors to instill confidence.

mine also worked just right now, I hope team work on fixing their DNS issues, This my last time dealing with this payment gateway, I haven't slept for 18 hours 


I get what you are saying. And it was DNS issues. I’ve done this many times and what you experienced is exactly what happens with DNS resolution issues. I know of no other circumstances that produce this issue. That your domain was only 3 days old makes sense with everything. I unfortunately have no experience with other gateways to say who is faster. I’ve only been doing this 2 and a half years and I stayed working only on the weekends for the first year and half.

I wish you the best of luck with FirstData or whomever you decide to integrate with. If your question is answered (even with an answer that is disappointing to you) can you mark this thread as solved?

It is the DNS resolver. This is totally separate from your domain. No one is saying that your domain is faulty. It takes several days to consistently resolve a new domain name. During this time period (3 days seems to be kind of consistent thus far) connections to your endpoint will be on and off.

So they should add that to their documentation or the developer guide at least! I wasted too much time debugging the issue!

All the android apps supported for All platforms.Get the latest android emulator


This is marked as solved, but I'm still getting the wrong event even after a 3 day wait and double checking the url success... Can this issue be brought back?