Showing results for 
Search instead for 
Did you mean: sent me here to see if I could get some help with this issue

I have a shopping cart that sends all the required x fields to, which works fine. Credit cards are validated correctly but the relay response won't work. The error I get from is "script timed out". This script collects the x values and updates a MySQL database to capture the invoice. When the script started timing out, I removed everything except to echo the x_cust_id, and nothing else.


I can run the relay script from the browser and it runs just fine.


Anyone have any suggestions why this timeout is happening on such a simple script? I've worked online with the Authorize.Net people and they don't have any suggestions.


Accepted Solutions

Just try it with the

it work with the relay response.

Something is not updating.


Just try the name again, it failed

and look at my ipconfig /displaydns

it show the ip as

View solution in original post


Relay Response Basics and Troubleshooting

Have you try just a static screen first.


I have simple perl script that just reads all input paramenters, prints a header and prints one of the x variables. Here is the script:


As you can see, there is no delay orr timeout involved.

Is that what you meant by a "static screen"?

static html page. no logic, no anything.

I create a page that is just a basic html page here:


I changed the x_relay_url to point to that page, and I changed the Relay Response in the backend to point to that page.


I submitted a new transaction.


Same time error.

Hello @phils 


I tried accessing your URL from my browser and it times out as well.  The Relay Response URL must be available publicly, it won't work if it's behind a firewall or uses a port other than 80 or 443.



Are you saying that you can't access That is a plain html page in the root folder of the webserver, the same location where the default index.html file is.

That is correct.  I cannot access either the specific URL you provided, nor the root.


After a bit, it returns: Network Error (tcp_error) A communication error occurred: "Operation timed out"



Richard, I was able to get to the page without issue.


phils, did the DNS(ip address)got update recently?


The only time I got a time out is if I add www in front of