Showing results for 
Search instead for 
Did you mean: 

codingerror on Moodle Transaction

I've downloaded the latest plugin and installed in a Moodle 2.4.3 system.  I'm getting the following when the user submits a transaction.


Debug info:
Error code: codingerror

Stack trace:

  • line 1092 of /lib/dml/mysqli_native_moodle_database.php: coding_exception thrown
  • line 1149 of /lib/dml/mysqli_native_moodle_database.php: call to mysqli_native_moodle_database->insert_record_raw()
  • line 281 of /enrol/authorize/lib.php: call to mysqli_native_moodle_database->insert_record()
  • line 63 of /enrol/index.php: call to enrol_authorize_plugin->enrol_page_hook()

Output buffer: <div class="mdl-align"><p>This course requires a payment for entry.</p><p><b>Authorize.Net Payment Gateway</b></p><p><b>Cost: USD 2</b></p></div>


Any direction would be greatly appreciated.


I tried uninstalling and reinstalling but that didn't change anything.  Still not able to use the plug-in.  Does anyone have the same problem or know why this might be happening?


Hello velocedge,


Which plugin for moodle are you using?  Have you also looked in the Moodle forums?



version.php says 2012051300;

I downloaded it from:


I have not posted on Moodle yet.  I thought you would be the better source of information since I don't know if is officially supported by Moodle 2.4.3.

Should I be able to run with Moodle 2.4.3?... is anyone else running it on that Moodle version?

@velocedge wrote:

Should I be able to run with Moodle 2.4.3?... is anyone else running it on that Moodle version?

Hi.  I realize this thread is a little old but I've just installed the same version as mentioned above and am using it just fine with Moodle 2.5.2.  I did make two changes.


First, there's a typo in the code at Github:


In enrol_form.php, line 168 is currently:


                $mform->setType('ccountry', PARAM_ALPHA);
and should be:
                $mform->setType('cccountry', PARAM_ALPHA);
(There should be 3 letter c's in a row)  Otherwise it throws a "type not set" warning when writing into the database.
I also downloaded the current SDK and used that instead of the one supplied at Github.