Showing results for 
Search instead for 
Did you mean: 

relay_response not working

I have a test account and am trying to use the relay_response feature. It works with my production account. I consistently get the message that the transaction was successful, but there was a problem with my web site. I've tried using my real URL and


Is there somewhere in the UI I can authorize an URL for my test account?


What you are seeing is a timeout error. Full error text displayed to the customer is “An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error.  The following is the result of the attempt to charge your credit card.”


Timeouts generally occur when you are using SIM API if you are using a Relay URL which is not publically accessible, not on port 80 or which exists behind a firewall that prevents us from connecting to it.


Additional information regarding timeout errors can be found in the online knowledgebase, located at

Trusted Contributor
Trusted Contributor

I am having exact same problem and was wondering the exact same thing. Have you found a fix for this problem. ??


I am having the same problem. My url is not behind a firewall.  It is publically viewed.  why is this not working?


We are having the same problem, behind a firewall but a public site communication should not be a problem.  Most of the time the timeout failure does not occur, but perhaps 5-10% of the time it does.  Cash received but local record not updated so transaction on our side not marked as completed.  Customer calls merchant to wonder if payment really received. 


The problem is the short timeout that uses. 10 second timeout we are told.  Very short! and does NOT retry at all. so it just fails. should either increase timeout to longer time, or retry.  We have other clients using PayPal, they retry serveral times and we have NEVER had this sort of failure over the past several years.  If is not willing to address this problem, we will need to recommend our clients take their business elsewhere, which we don't want to do since the on-line transaction management tools work well.

Pleeeeeese tell us that will address this issue.



My test account has the same problem since Oct.

my credit cards dont work thru my website the lady that I been working with on my website is Candice she says that she got Request rejected by FDC omaha-Invaid merchant number can you try and help me



We are having exactly the same problem.


In a small percentage of the cases, Authorize makes no attempt to contact the relay_response url. We have verified this all the way down to examining our boundary firewall logs looking for any possible connection attempt. There was absolutely nothing there - absolutely no attempt to contact the relay_response_url.


I have had two support chats with Authorize on this.

The first one said that the relay_response sometimes had intermittent problems (!!!!), and that it would be solved if i specified the relay_response_url in the Manager settings instead of sending with each transaction.

We have done this on a temporary basis - but the jury is still out on whether that solves it. This is not a permanent solution for us anyway.


I had a followup chat a few minutes ago that said that the first tech was wrong and there is no problem.

The second tech was EXTREMELY unhelpful, basically telling me to go away (i.e. i'm not going to help you). He followed up with "if this was a real problem, other people besides you would be complaining".


So on behalf of all of us, here's what i'm going to do:


To the Authorize Representative monitoring this forum. Please take action to investigate this immediately. If you contact me, i would be more than happy to provide you with the chat logs from those technicians, and full detail about the affected transactions and lack of response.

If no action is taken on this, I will take the next step and post those chat logs on this forum - and proceed to spread the word accordingly over the communication channels at my disposal.


My company regularly recommends various payment vendors such as Authorize. In this particular case I am loosing money because of this problem (I can't force our consulting client to pay for extraordinary problems with a vendor that we recommended).

Thanks everyone for your posts. There currently is an issue with test accounts and Relay Response. Our teams are looking into the cause of it now and once we've figured it out and fixed it, we'll respond to this post and let you know. I apologize for the inconvenience. Please note though, this issue is only in the testing environment.


Regarding the use of Relay Response using a live account, there is indeed a timeout period after which we do not retry. I am forwarding your suggestions about increasing the timeout and retrying the attempt a couple of times to our product team.


And Paul, I'm very sorry you had such a negative experience with your second chat. If you would please send a private message to me with the details of that chat, I would appreciate it.


Thanks again everyone for your posts,



Developer Community Manager

Wondering if this is a related issue. I am trying to implement SIM. I am using a hosted payment form and have a relay url set up to simple echo the post response. However it immediately gives an error: ________________ An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card. This transaction has been approved. ________________ I switched the relay url to Now I get the same error, but after approximately 12 seconds. I am using a live account in test mode. Is this a related issue? If so, any ETA on the solution?