Showing results for 
Search instead for 
Did you mean: 

transactions not working anymore with USA (working only with UK)



we are receiving this error message below for all new transactions since yesterday evening.
this is happening on production account (developer account works fine).
this is happening for USA account (UK account works fine which is using the same scripts).
we have not changed anything on the server or on the account settings.
any suggestions?

thank you


-----Original Message-----
From: Authorize.Net []
Sent: Tuesday, February 28, 2017 8:53 PM
Subject: Transaction Error Notification

Authorize.Net Merchant,

Your script timed out while we were trying to post transaction results to
Transaction Result: This transaction has been approved.

The following message was displayed to the customer:

------------------------------An error occurred while trying to report this
transaction to the merchant. An e-mail has been sent to the merchant
informing them of the error. The following is the result of the attempt to
charge your credit card.

This transaction has been approved.

It is advisable for you to contact the merchant to verify that you will
receive the product or service.



Hello @ST1


This error suggests that Authorize.Net is unable to connect to your relay response URL after successfully processing your transaction request.  If it works properly in sandbox but has started failing in production, it would suggest a change with your server preventing us from connecting.



Administrator Administrator

thanks for replying Richard,


we have not changed anything on the server.


the relay response URL seems to work fine when is sending unsuccessful transactions. but the successful transactions never reach our server.


the relay response URL is not blocked by our host.


furthermore, we are using the same scripts for another account (UK) which works fine. this makes me think that it may be a problem with the account USA only, versus something on our server.


the owner account is verifying with support those specific transactions ID that are successful but not redirected to our server. I'm not sure what to check next on my side.


Any update on this? I don't have access to our customers' live accounts but we're seeing a similar behavior where there are a LOT of timeouts starting today.


My immediate concern is I hope people aren't making duplicate payments by trying again

Switching from to in our AIM connection ( seems to have helped.


Something is wrong with the new URL?

Hi mgroger,


thanks for replying. we have open a ticket with support and the problem has been solved. but they did not specify what they may have done.


for info and addressing your concern:
- we never used '', only ''
- we prevent duplicate payment to be posted to (preventing double-click)
- we never had any timeout issue, successful transactions were processed right away but not relayed back to us (unsuccessful transaction were properly relayed)


we have not changed anything on our side, but it works now.