cancel
Showing results for 
Search instead for 
Did you mean: 

Cybersource simple order api sample application gives "The type initializer for 'CyberSource.WSSecur

Hi

I was running the simple order api sample application using SOAP which we can download from Cybersource official website. I changed the merchantid and securitykey path as per documentation . But wheneve I run the application im getting error

"The type initializer for 'CyberSource.WSSecurity.Signature' threw an exception."

I browsed through various post, but nobody tells clearly what to do . I have installed MS WPE 3.0 but still getting same error.

StanGilbertland
Contributor
1 REPLY 1

I got it resolved after i generated a new soap-toolkit key from cyber-source business center and used it in my application .

Make sure the web server have the Microsoft WSE 3.0 addon installed.

Install the MS WSE 3.0 addon on the server. That is a free download from https://www.microsoft.com/en-us/download/details.aspx?id=14089

Additionally if you are trying to use this on something newer than XP/Win 2003 and using iis7 or above: make sure your app pool has Enable 32-bit Applications as TRUE.

 

paradox
New Member