Showing results for 
Search instead for 
Did you mean: 

Error while using SOAP API of cybersource

I am trying to use SOAP based Cybersource payment gateway service. Currently I am trying to use Test environment that Cybersource provides for testing sample test credit card transactions.

  1. Created a project in SOAP UI using the WSDL :

  2. SOAP UI generated the test method runTransaction.

  3. I copied the same SOAP message provided in Cybersource documentation in to SOAP UI as the SOAP message, which I have given below.

  4. When I send this request, I am getting the following error:

If anyone has worked on this before or faced this issue, please provide pointers. Thanks!


I ran into this same message.

Unfortunately it's not conclusive what the exact error might be, but I found that mine was due to a malformed Security header. (Which is not very intuitive from the error message.)

I don't see anything immediately wrong with your Security header, but you might double check your namespaces.

I had the same problem. The url for the wsse namespace has an extra ' ' (space) that shouldn't be in there on the 3rd line of your XML. The URL should be:… /omegle /shagle voojio with no space preceding the /wss/ wss



I have same issue..