cancel
Showing results for 
Search instead for 
Did you mean: 

What Is It?

This blog post is intended to explain the compatibility of the two Cybersource REST SDKs for .NET Language with the Microsoft Frameworks in order to ensure that merchants are able to select the correct one for their environment.

Audience

Any merchant that uses Cybersource REST SDK for .NET. from either Github .NET SDK or Git Hub .NET Standard SDK

Details

.NET Frameworks published by Microsoft have changed over time to support evolving operating systems as well as offering better & faster performing frameworks. While the clients for REST SDKs can use one of the many such platforms of .NET, we have summarized below the compatibility of the Microsoft .NET framework and the corresponding Cybersource REST SDK that should be used with it. This information is to help merchants choose the correct SDK based on the available framework.

Compatible version of SDK with .NET versions

Client .NET Framework Application

Compatible Versions for Cybersource SDK

Cybersource SDK

GitHub Link

NuGet Repo Link

.NET Framework

  • v4.6.1
  • v4.7.2
  • v4.8
  • v4.8.1

.NET Rest Client SDK (built on .NET Framework v4.6.1)

Github .NET SDK

Nuget Cybersource Rest Client .NET

.NET or .NET Core

  • .NET Core 3.1
  • .NET 5
  • .NET 6
  • .NET 7

 

.NET Standard Rest Client SDK

(built on NetStandard2.1)

 

 

Git Hub .NET Standard SDK

 

 

Nuget Cybersource Rest Client .NETStandard

.NET Standard

  • .NET Standard 2.1

 

rajvpate
Administrator Administrator
Administrator