cancel
Showing results for 
Search instead for 
Did you mean: 

An error occurred while processing your request. Reference #97.

I originally posted this as a reply here on Jan. 5th:

https://community.developer.authorize.net/t5/Integration-and-Testing/CIM-is-sporadically-up-and-down...

 

But haven't received a reply, and we are still experiencing this problem.

 

We've been getting this same error, and discovered it's been happening since June 2017.  In our case, it's not sporadic -- it happens every time.  We only discovered the problem now, since it's an automated process used to pull transaction data for reporting purposes (the client noticed data was missing when attempting to view the year-end numbers).

 

I tried calling support, and also submitted a support ticket developer.authorize.net, but they directed me back to this forum.  Details:

 

Posting XML SOAP 1.2 requests to https://api2.authorize.net/soap/v1/Service.asmx

 

Sample error message:

"An error occurred while processing your request.
Reference #97.c93de93f.1515015926.4df6249"

 

Calling the service from a daily PHP cron job on a GoDaddy shared server.

This had been working for a couple years (since 2015) before the error started to occur, no changes were made to the script. Using the API to call GetSettledBatchList and GetTransactionList.  But even AuthenticateTest produces this error.

 

-Andrew

nupathenergy
Member
3 REPLIES 3

Hello @nupathenergy

 

The response is the same from the previous thread.  In short, you are connecting to Authorize.Net via the Akamai network and they are intercepting and blocking your connection.  To resolve, you'll need to do the following as reported before: 

 

If you are using an api2 endpoint and are receiving an html response including a reference number, please contact support by phone immediately and provide them with the reference number.

 

The reference number indicates an issue outside of our network that must be escalated within 24 hours before the data associated to the reference number is purged.

 

Richard

RichardH
Administrator Administrator
Administrator

Make sure that in your display settings the Scale and layout is set to 100%.

BobCardwell
Member

I resolved my issue. Thank for your reply.               fireboy and watergirl

whatscore
Member