Showing results for 
Search instead for 
Did you mean: 

Android Card Present AIM Intergration : Error E00000

Hi ,


I am doing an integration of my android with sdk to accept card present transactions. Every thing works fine  except to the ponit when we submit the transaction for processing, we are getting an error E00000 - Unknown error. We are not able to find the root cause of this error.


Can you please help? I have already spent 3 days trying to debug this.






   I am also facing same issue. I  have tried sending both track1 and track2 data, but it is throwing Unknown error. If your problem is solved. please help me with this. I am using IDTECH Unipay Card reader.

Hi RiteshMishra,

    Is your problem Solved. If, so please give me the details how you solved it. I am also getting the same issue.


Thanks in Advance,

Have you looked at the sample Android application on GitHub?

Hi Richard,


     There is no integration of card swipe in the sample application. So, i am setting track info like this


String refId = Long.toString(System.currentTimeMillis());
BigDecimal totalAmount = new BigDecimal(pay_now_total);

CreditCard creditCard = CreditCard.createCreditCard();


Order order = Order.createOrder();
order.setTotalAmount(new BigDecimal(pay_now_total));
order.setDescription("Android Test Order");

Customer customer = null;
Address shippingAddress = null;
ShippingCharges shippingCharges = null;
EmailReceipt emailReceipt = null;
HashMap<String, String> merchantDefinedFields = new HashMap<String, String>();
merchantDefinedFields.put("notes", "sent from SampleActivity");


Intent authNetIntent = authNetObj.createAIMAuthOnlyIntent(DashBoard.this, refId,totalAmount,
creditCard, order, customer, shippingAddress,shippingCharges, emailReceipt,
launchSubActivity(authNetIntent, createPaymentIntentResultCallback());


I have removed first and last character of track2 and sent it. It is throwing me E00000: Unknown error.


Your correct, there is no example of the using the swipe in such sample stated above ! Right now i am only able to use the Shuttle both Production and Developer version using the production app from Play Store. I have not been able to get the swipe to work using the sample app in Github.


If anyone has a sample app that has been able to get the swipe to work please share it in Github. Thank you


 Swipe is working fine after i added the line in the code.


CreditCard creditCard = CreditCard.createCreditCard();