Showing results for 
Search instead for 
Did you mean: 

C#, dll, vista

//Error 1 The type or namespace name 'AuthorizeNET' could not be found (are you missing a using directive or

 //an assembly reference?) C:\Users\Marie\Desktop\Authorize_Net\C#\Sample_MP\Sample\AIM

//Example\Auth1.cs 5 7 AIM Example


using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using AuthorizeNET; // This is the problem****

namespace SampleAuthorization {
    class Program {
        static void Main(string[] args) {
            //step 1 - create the request
            var request = new AuthorizeNet.AuthorizationRequest("4111111111111111", "1216", 10.00M,
                "Test Transaction");

            //step 2 - create the gateway, sending in your credentials
            var gate = new AuthorizeNet.Gateway("", "");

            //step 3 - make some money
            var response = gate.Send(request);

            Console.WriteLine("{0}: {1}",response.ResponseCode, response.Message);


I am an old c+ programmer attempting to get the AIM to work.  I was unable to get the coffee shop sample to open.  

The code works if I comment out the reference but what is the effect.

I have read the manual and searched the forums and don’t find the answer to the above problem.


The dll’s are loaded under the Reference.

My OS is vista 64-bit.

I am running in admin mode.

Again, It will build if I comment out the reference.

AIM file was downloaded 12/26/10

I have tried removing and re-adding the reference.

Any suggestions?


Thank you,



hope this is not a stupid question - have you added the a reference to the dll in the project? (presuming your using visual studio)


<-- Kudos is always welcome....

Trusted Contributor

Im sure youre past this by now, but for archive Project properties, under "target framework" change it from "3.5 client" to "3.5". it worked for me.

Thanks for the response. Setting the target framework is a problem with their samples.