Showing results for 
Search instead for 
Did you mean: 

Cert.pem expired. Why. Why Why.

Suddenly started getting "Error connecting to AuthorizeNet" response. We use the older SDK (that does not require composer).


After a couple hours of searching, I tried various cert.pem files until I found one that worked.


How do we get notice that the cert.pem needs to change?

I tried the cert.pem from the NEW SDK and it did not work, why not?


Having the same problem, anyway you could tell me which one worked for you?






I was having this problem as well and was able to fix it by using the cacert.pem from the latest version of active_merchant:


Hope this helps someone else who has been pulling their hair out...


You're a life saver, thank you!  Working on my site now as well.


This cert and others are not working for me.


I called suppoert and got this:



With issue connecting with anet and receiving an SSL error of some kind you may be validating against an old certificate that we are no longer using.    

Our current certificate is: 

Entrust Certification Authority - L1K 

This information is also publically available by running an scan against our endpoints.   


Thank you for contacting Customer Support.


Authorize.Net Customer Support


To tell you teh truth, I'm so far removed from this install at this point I'm drawing blanks as to where/how to update this - feel like a newb today, and not sure how to solve this and it is costing sales every minute I fumble. Anyone have any other ideas?

I got the same thing from support. Where do I put this cert. I never had to install a cert when I initially used a php library to make this work.

The .cer file they provided when converted to a .pem and a hashed symlink is created did not solve this problem for us.

I've also tried the other ca-bundle.crt files posted here and elsewhere, they are not solving the problem either.


Anyone else?


I have found joy.


The email they sent was not what worked for me in the end.


I replaced cert.pem on my server (I use PHP - it was located in ) 


with the chain file contents of:


(As was suggested by another poster. My first failed result was caused by my own error.)


All g.






Where does this .pem file have to go.  I have php and rails apps with passenger using  Does it go in Apache conf? Or is this a system wide thing?