Showing results for 
Search instead for 
Did you mean: 

Getting Error E00001 in Sandbox When Trying to Delete Customer Profiles

Getting Error E00001 in Sandbox When Trying to Delete Customer Profiles. Nothing has changed in the sandbox account that we can tell. Was working fine yesterday. Just started this morning. We have retried sveral times with the same error.


To note: Getting a list of customer profile ids works fine. It just erros when we try to delete by the customer profile id. Again this worked fine yesterday.


@RichardH This is working for us this morning now. Thanks!

We are stilling haveing the issue this morning in the sandbox.  Any ETA on this?




We're scratching our heads on this one because we cannot duplicate. We're able to delete customer profiles at will and our automated testing shows the same.


Is it only this API method that does not work, or are you unable to connect for other api calls?


Let's also get some details on if you're using our API or an SDK, which version and language.



We are using the C# .net SDK.  getCustomerProfile and getCustomerPaymentProfile are examples of failing requests.  We are using version 1.9.3 of the SDK.



@kylepauljohnson  Are other API calls successful or is everything failing?

Pretty much everything we call to you at this point is failing.

@kylepauljohnson OK this perhaps is a different problem than reported by the OP.  Our sandbox now requires a TLS 1.2 connection.  Are you able to sniff the connection and determine if your system is able to make a secure connection?



Ok I think we just foudn the issue.  The transaction key appears to have gotten changed and expired about the time mentioned earlier.  So after generating a new one all seems ok again.

@kylepauljohnson Glad you were able to find the issue.