cancel
Showing results for 
Search instead for 
Did you mean: 

How to Suppress Customer Email Receipt for Authorization Only Transaction?

I am using an "Accept Hosted" form for transactions.

 

When the visitor submits their credit card, they get a receipt email -- even when it's an "Authorization Only" transaction.

 

This is not good. It makes the visitor think their credit card has been charged, when it has not.

 

In the old AIM API system, there used to be a parameter "x_email_customer" which you could use to suppress the customer receipt email.


But I see no such parameter for the getAnAcceptPaymentPage function to create the payment page.

1 ACCEPTED SOLUTION

Accepted Solutions

My bad. There is a solution. The following 4 lines of code accomplished what I need:

 

$emailCustomerSetting = new AnetAPI\SettingType();
$emailCustomerSetting->setSettingName("emailCustomer");
$emailCustomerSetting->setSettingValue("false");
$transactionRequestType->addToTransactionSettings($emailCustomerSetting);

 

It is documented on this page:

https://developer.authorize.net/api/reference/index.html#accept-suite-get-an-accept-payment-page

 

Look under "Accept Suite" > "Create an Accept Payment Transaction" > "REQUEST FIELD DESCRIPTION" > settingName

 

My apologies to Authorize.net.

View solution in original post

5 REPLIES 5

  1. Log into the Merchant Interface
  2. Click Account from the main toolbar.
  3. Click Email Receipt under Transaction Response Settings.
  4. Select or deselect Email transaction receipt to customer (if email address is provided) krogereschedule
Earnest
Member

Thank you so much for your reply.

 

I believe your solution would suppress receipts for all transactions.

 

This is not what I want.

 

I want the receipt turned off for "Authorization Only Transaction" only.

Did you have a fix on this issue? I have the same problem with

I faced similar kind of issue last time, I am still searching for some proper   Popeyes Survey  solution

I have exactly the same problem. Anyone got a suggestion?

Robertson_87
Member

Thanks so much for letting me know that I'm not the only one with this issue. Good to not be alone. And maybe this will increase the chances that Authorize.net will address the issue.

 

Unfortunately, no solution yet. I'm considering just sending an automatic email explaining to our users in this situation, explaining that the email from Authorize.net indicates only that their credit card was verified, but that no charge was made.

 

The truth is that in my opinion, no parameter should be required -- Authorize.net should not be sending people a purchase receipt when their credit card is not charged and no purchase has been made. Only later, when the transaction is later "captured", to use their terminology, should it be sent.

 

At the very least, in the "authorize only" situation, Authorize.net should tweak the wording of the receipt to indicate that no actual charge has yet been made.

 

In any event, since the "accept hosted" form accepts a parameter to indicate the transaction type, it should also accept a parameter to indicate whether or not to send the receipt. I looked fairly thoroughly through the documentation, and poked around the Authorize.net php files, and it doesn't look like there is anything to address this.

My bad. There is a solution. The following 4 lines of code accomplished what I need:

 

$emailCustomerSetting = new AnetAPI\SettingType();
$emailCustomerSetting->setSettingName("emailCustomer");
$emailCustomerSetting->setSettingValue("false");
$transactionRequestType->addToTransactionSettings($emailCustomerSetting);

 

It is documented on this page:

https://developer.authorize.net/api/reference/index.html#accept-suite-get-an-accept-payment-page

 

Look under "Accept Suite" > "Create an Accept Payment Transaction" > "REQUEST FIELD DESCRIPTION" > settingName

 

My apologies to Authorize.net.