Showing results for 
Search instead for 
Did you mean: 

I am getting zero on reponse

Hi, I have integrated payment gateway. it is working fine but on response i am getting as :Success! Transaction ID: 0 Approval Code: 000000 can anybody suggest me, why i am getting as 0


Hello @ajaydubey


A transaction id of ZERO indicates your gateway is in test mode, or  you are submitting your transaction request with testmode = true.  You must be in live mode or the gateway will only validate your credentials.



Administrator Administrator

I too am getting a 0 response. However, I am in live mode. On April 15th, 2018 I upgraded to TLS 1.2, prior to the upgrade AN was not recognizing the cc submissions. I have checked with my host company and they say my whole server is now 1.2 compliant. After the upgrade, I checked the whole processing system, and it worked fine. Now today, and for who knows how long, my system is acting the same way it did prior to the TLS upgrade, where AN is not recognizing the submissions. Meaning - our system will send out the transaction code, but AN will not respond.

So, if it worked after upgrading to TLS 1.2, and so I know the code on our end is fine, what would make us get a 0 response from AN, after initally getting positive responses...?


I figured out in talking to customer support that my link had been depreciated, and that all I had to do was point my link to one of the Akimai servers, and that fixed my problem. Supposedly AN, depreciated older servers on May 1st. Hopefully that will help someone else....