Showing results for 
Search instead for 
Did you mean: 

Java code returns null values from postTransaction()

Hi There,


I recently setup my Java environment to use the AIM SDK. I've just started making aithorization attempts now and I don't seem to be getting anything back when I run merchant.postTransaction();


I had the same code working in a serperate Java project in Eclipse and it worked fine. I have now moved the code to my main project (with dependencies) and get the following errors.


The return values are like:


RRC_0_0 : null
Transaction Id:
Auth Code:
Response Text:null
Response Code:ERROR
Response Reason Code:RRC_0_0


As you can see they are either emtpy or null. Or in the case of the reason code, 0. Which is invalid according to the error tool.


Any ideas on what is causing this problem would be greatly appreciated.


EDIT: I forgot to mention that I am using AIM.





Can you trace/spy the process to see exactly what it's sending?


I am having a similar issue from a VM host which uses a proxy in the GPO (IE has a proxy server listed).


My Java call works fine from a local machine (without the proxy).  What do I need to do to have the Java API calkl working with the proxy from the VM machine.




Hello Guptas123

It doesn't look like anyone has responded yet, but someone still may have feedback on what you're looking for. I'd recommend subscribing to this topic so that you'll be alerted via email if anyone else from the community is able to respond with any comments. To subscribe, click Topic Options at the top of this thread and then select Subscribe. You'll then receive an email once anyone replies to your post.