Showing results for 
Search instead for 
Did you mean: 

No Relay Response when using IP address

I am in the process of changing web hosts and doing some testing before changing over the nameservers to the new hosting account, so my x_Relay_URL has to use an IP address for now. The domain name and security certificate are still in use at the live site at the exising web host. 


The problem is, despite what I have read in other threads, relay response doesn't seem to work when using an IP address in place of a domain name. There is no attempt to send the transaction response, just an instant posting of the error message..."An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error...................."


I know the theory is that this will work with a publicly accessable URL, but I have my doubts. I have tried changing the domain name to the IP address on a fully working installation and encountered the same error.


Has anyone actually done this successfully?


I assume you configured the IP-based relay response URL in your account control panel? According to this post, you ought to be able to use IP's, assuming they're not https URL's:



This was all done in the test account. I tried both http: and https: joy.

I got it working now....had a mistake in the url.