Showing results for 
Search instead for 
Did you mean: 

One account works another does not, resetting Transaction Key doesn't help

Godaddy host with SHA-2 cert

WordPress with Gravity Forms and the add-on.




Switched hosts a couple weeks ago, payments now aren't working properly. Switching the ID and Transaction Key to another account seems to make everything work again. What could be wrong with my main account? I've tried resetting the transaction key and no luck.


When the user submits a form it spins forever and never gets a response to move to the confirmation page. Sometimes the payments go through but it still doesn't send back a response.


To verify it wasn't WordPress/Gravity Forms I tested my ID and Transaction Key with the sample PHP AIM code and get the same problem, it spins and spins and nothing loads, don't even get back an error message or code.






To clarify a little more. As soon as I change the Sample PHP AIM code to another account's ID and Transaction Key it works perfectly.


Hello @sethstevenson


Can you duplicate this in the Sandbox, or does it only occur in production?



Only in production. We JUST got Godaddy to switch our cert to SHA-1 and still no luck, thought that might be an issue since I saw the SHA-2 announcement.

My Poco F1 phone gets factory reset when it is in the coverage range of my JioFiber WiFi.
Reset pattern is not same, sometime it resets within 30 minutes and sometimes it resets in 4-6 hours.
Have to configure my account again and again.
Tried changing my google password, WiFi SSID and password . router reset and even router replacement.
How to check what kind of command router gives to phone to go for factory reset and how to prevent it.
Phone resets even if both mobile data and WiFi on handset are turned off.
Device has enough free memory and only 18/128 gb is used.
I tried using other devices but same thing happens