Showing results for 
Search instead for 
Did you mean: 

SSL Timeout Connecting to Sandbox

The CIM API is timing out for us.  Is anyone else having this issue or is it just us?


@lethjakman: For nginx, I believe you change /etc/nginx/sites-available/default instead:

ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;


"Move fast and break things," out. "Move carefully and fix what you break," in.

We are going to make a change tonight to which ciphers are currently in place, as we believe this will help resolve the issue for those who haven't seen improvement by upgrading OpenSSL or by forcing SSL v3. The list of ciphers I gave earlier should remain in effect.

"Move fast and break things," out. "Move carefully and fix what you break," in.

What time and timezone will those changes take place, will you post back here when updated, or tweet the update?

We're going to start the change at around 10 PM Pacific time. We have a four-hour release window for this, so you should be able to test the changes at 2 AM Pacific time.

"Move fast and break things," out. "Move carefully and fix what you break," in.

This did the trick. Great solution bbot, saved me many hours.


curl_setopt($curl_request, CURLOPT_SSLVERSION, 3);


To line 93 of AuthorizeNetRequest.php in the PHP API fixed the problem.  Thank you for your help.


          I am facing the similar problem since yesterday Morning EST , we are using sample PHP ARB script it was working fine on our website but all of sudden .


                      The problem is not implementation of code , the same sample code is uploaded on another server it works fine and return with the response but as I mentioned in the email

on client server its not doing the same , though before it was working fine yesterday.

when we execute the page it come with blank response.

AuthorizeNetARB_Response Object
    [xml] => 
    [response] => 
    [0] => 

Please help.

Hi ,

      we are using ARB sample test script on server and it was working fine for us also till yesterday, but all of sudden it started sending blank response. have you find any soulution? please help

Hey for me also it worked :smileyhappy: it had just frustated since yesterday.

What changes were made last night? I am still not able to connect. I'm trying now with 





For those using fsocketopen, use "sslv3://" as protocol. For example:


$url = "sslv3://";

$port = "443";


$fp = fsockopen($url, $port, $errno, $errstr, 30);


It worked for me.