Showing results for 
Search instead for 
Did you mean: 

Sandbox: Error getting valid response from api

Yesterday we started getting this error on out development server, "Uncaught Exception: Error getting valid response from api.".

Our production checkout is working fine, but when trying to create a new profile using a test CC#, it fails.


Has something checnged on




Regular Contributor

What's strange is the sandbox works from our staging server. But the code is the same.

I'm now catching the exception and the error is the same. When I look at the Authorizenet.log file the transaction stops at the response.


authorizenet/authorizenet/lib/net/authorize/util/HttpClient.php : 96) - Response from AnetApi:

It just ends there.


Any help appreciated. 

BTW, using the PHP SDK v1.9.9 and I have the latest cert.pem

Regular Contributor

Upgraded to 2.0.0 with no change

Regular Contributor

Hello @fifty-git 


Have you tried using Wireshark or similar tools to isolate where communication breaks down?



I hadn't before your reply. I've installed wireshark locally and now I'm reading network traffic over ssh using tcpdump. But I really don't know what I'm looking for.


When I try to do a checkout on our dev, I saw this go by. with in black and red...

434747	515.610095	TCP	66	[TCP Previous segment not captured] 64742 → 22 [ACK] Seq=146989 Ack=441873649 Win=8619 Len=0 TSval=435510312 TSecr=1127518184

434748	515.610115	SSH	1314	Server: [TCP ACKed unseen segment] [TCP Previous segment not captured] , Encrypted packet (len=1248)

I'll have to figure out what this means


- Don

Regular Contributor

well, I did a reboot on our aws instance and that fixed it.


Sorry for the messed up post.


- D

Regular Contributor