cancel
Showing results for 
Search instead for 
Did you mean: 

Sitecore SES Using Authorize.Net as Payment Provider

I have a Sitecore 7.2 website, running SES 2.2 that uses Authorize.Net as it's payment provider.

For the past couple of months, we have been able to send test orders through to Authorize.Net using a Sandbox Developer account, however, now as we approach the launch of the website, we cannot get through to the live Authorize.Net account.

In our Authorize.Net content omegle.2yu.co item, under Sitecore/Content/Home/Business Catalog/Payments/AuthorizeNet we have updated the username and password to those provided to us by Authorize.Net for our live Merchant account, updated the payment provider URL to https://secure.authorize.net/gateway/transact.dll /omeglz /echat and in the settings change x_test_request to FALSE.

The content item has been saved and published to web.

However, we cannot get through to authorize.net to accept payment.

We have spoken with Authorize.Net's developer support and were told that the error can be triggered by 1 of 3 things:

  • The account is inactive (we know this is not the case, because I was currently logged in).
  • The site code / shopping cart settings are posting to the test URL (the rep confirmed we are posting to the proper url)
  • The Transaction Key and/or API Login ID is invalid.

We have entered the Transaction Key (password in content item) and Login ID (username) exactly as provided by authorize.net, but still have not had any luck.

Has anyone experienced anything like this?

0 REPLIES 0