Showing results for 
Search instead for 
Did you mean: 

Track 1 Data Invalid Format

We are trying to get card present transactions working.


I am sending track1 data. Prior to sending, and after LRC verification,  I remove the first character (%) of the track1 string

and the last character (?).  What we are getting back from Authorize.NET is  "Track1 Data is not in a valid format".

Not sure what we are doing wrong?


Thanks in advance.



Here is some example track data:


track 1

track 2



Thank you,



Trusted Contributor
Trusted Contributor

I'm not a developer but a user and I'm receiving this same error.  I'm using a card reader/printer on my cell phone and recently switched from Blackberry (where all was working fine) to an Android.  Any time I swipe the card, I get either the "Error - Track1 data not in valid format" or it says "reading swipe" and never comes back.  I'm successful with a manual entry of the card info - just the swipe is a problem.  The vendor says it's the reader/printer but to me, it's very coincidental that it worked fine on the last day I had the Blackberry and the next day on Android - it's not working.


Any thoughts?

This type of problem can really only be investigated by someone that is familiar with the software that is interacting directly with the card reader.  It does seem unlikely that the card reader just happened to break when you switched devices, but there is just no way of knowing without seeing what data is actually being pulled from it.

Does it matter if track1/track2 data contains white spaces? For instance, would this be a legal string?


"B4000000000000002^CardUser/John    ^131210100000019301000000877000000?"



White spaces are common in the name field within track data, it wouldn't cause a track data error.

Administrator Administrator