Showing results for 
Search instead for 
Did you mean: 

getSettledBatchList error 400 Bad Request

I'm using a https POST request with SOAP to call the getSettledBatchList service. I'm getting back a Bad Request 400 response. Why? Here's the request:


<?xml version="1.0" encoding="utf-16"?>
<soap:Envelope xmlns:soap="" xmlns:xsi="" xmlns:xsd="">
<GetSettledBatchList xmlns="">


Additional info: I am adding this header:

"content-type" ; "text/xml; charset=utf-8"

More info: Adding a trace resulted in this message: You don't have permission to access "" on this server.


(I am using the https version of the URL, so I don't know why the error message says http.)

error on the trace or the request?


400 bad request could be data or the header


how are you posting? where are you posting to?

posting to:


Sent from a database application (4D) that has an HTTP REQUEST command. I get an abbreviated error when I do the actual request: Error 400 Bad Request. I get the fuller error ("You don't have permission...") when I do the trace.

post to just the asmx or

or you set the soap action?

just asmx

Tried it. Same result.

Can yu try it other then using the 4D database?

or did you try just using the xml interface?


Request Method: POST

Sandbox URL:

Production URL:


XML Content-Type: text/xml

JSON Content-Type: application/json