Showing results for 
Search instead for 
Did you mean: 

/rest/v1/notifications/{notificationId} gets "The requested resource could not be found"

I am currently using Postman for testing.


When I GET I receive all my notifications such as the following...


"notifications": [
            "_links": {
                "self": {
                    "href": "/rest/v1/notifications/3c60e0e6-354a-409c-8e4e-4f04a718f14d"
            "notificationId": "3c60e0e6-354a-409c-8e4e-4f04a718f14d",
            "deliveryStatus": "Delivered",
            "eventType": "net.authorize.payment.void.created",
            "eventDate": "2018-04-23T22:20:09.93",
            "webhookId": "5d5819f9-bae5-4e7b-b9b7-694646b1c10e"

However, I want to get the "payload" so I can get the transaction id. I saw in another post that, in order to do that you just /rest/v1/notifications/{{notificationId}} . I tried this a couple of weeks ago and it worked fine...but now, for example, if I try to GET it returns...

    "status": 404,
    "reason": "NOT_FOUND",
    "message": "The requested resource could not be found.",
    "correlationId": "3a2707c9-3e4e-4bae-a17b-9da0b6247d08"

Any idea what might be wrong? Could it be something is wrong on's end? Or am I just doing something wrong somehow?




I attempted to make a new Transaction and see if I could get the payload with one of the new notification ids and it works. However, if I try to do it for the older notifications (such as from April 24th) it still doesn't. Is there some kind of expiration on these notifications?


Hi @jonCherlin1


Thanks for updating on it .

Looks like this is a bug in the API which  is restricting the fetch  of  older notifications . 


The team is looking into the fix and will update soon. 



Send feedback at

Anurag Thank you so much! Please keep me updated.

Has there been any progress on this? I still can't fetch older notifications.

The fix is done and its going through the QA cycle . 


will update once we have a release date for it . 



Send feedback at

Thank you!! Please let us know.



Please try now. You should no longer see 404 for your scenario.



~ Rajvi Patel