Showing results for 
Search instead for 
Did you mean: 

Accept.js - Sandbox: Library is not coming from Accept server

Today I attempted to deploy me application to a DEV server and I started getting the following error:  Library is not coming from Accept server--- a7e38542d3a404b4b3ac37a7252bca2e7f3dd724a357aa93ce22f413e74333c3


Here is the script I'm including:


<script type="text/javascript" src="" charset="utf-8"></script>


It works fine if you do the production url (, but it stopped working for me today when using the sandbox url.  I don't know what is happening.  To cut down on all variables, I literally created a blank html document with this script tag in the header and I still get the error message in the console.  It happens in chrome, firefox, and edge.  I've been testing successfully the last several days with no issues.  I'm stumped at the moment.  Anyone run across this?





I am seeing the same problem on my end.

The jquery is automatically adding ?=timestamp to which I fixed by temporarily disabling cache while loading the Accept.js script.


However,  I now see the error on the AcceptCore.js.  I can confirm that the dynamic ?=[timestamp] is no longer sent, but still I am getting 90:97 Library is not coming from Accept CDN.


0 !== document.querySelectorAll('script[src="' + c + '"]').length || k(z, b) || (y.warn("Library is not coming from Accept CDN."), m(b, C.messageInfo.E_WC_01)), "https:" === window.location.protocol || k(z, a) || (y.warn("An HTTPs connection is required to secure delivery of payment information."), m(a, C.messageInfo.E_WC_02))

Did anybody encounter this, how do I fix this ?


Any help is highly appreciated.


Thank you.



Any further update on this issue ?

Seems like the network change on your end from Akamai to Cloudflare has lead to this issue in the the sandbox environment ?


This is very frustrating, I see several people have the same issue but there is not enough response from the moderators.


I have tried clearing cache, cookies and all options suggested with no success.


Can somebody from AuthorizeNet IT team respond, ASAP please?

Hi Team, Could you please update the thread with proper solution. I am also facing the same issue with Sandbox enviorment. The error is not coming whenever I try hard refresh (Ctrl + Shift + R) in Chrome, though I can't ask testers to do that everytime. 


I'm facing this issue with production environment so I would like a solution very soon as my customers are starting to me really mad


Facing the same issue.


I published a web page with only the sandbox script tag, and still get the error.

No clearing of cache/cookies resolves the problem, either.

Hi Team,


Facing the same Issue, with setting up a Hosted Payment Form while integrating the Payment Gateway.


We have used the following Complete Example Script as mentioned in your HELP DOC :
But we are stuck with the following error CODE that we receive from the Console Log : 
"E_WC_03 Accept.js is not loaded correctly" and "Accept.js:1 Library is not coming from Accept server--- a7e38542d3a404b4b3ac37a7252bca2e7f3dd724a357aa93ce22f413e74333c3"
We tried the sandbox TEST link in the Javascript as mentioned below.
<script type="text/javascript"    src=""
See the below screenshot for the quick reference of the issue in the console log.

21 days since the original post, and I'm still seeing this issue...


Are there any strategies to work around this? Is there a fix in sight?

Hello Authorizenet team,


Are you watching this thread ?  

I have also call and talk to the support team, but they could not help either and just suggested that I should wait for an update on this thread.


Please help!!!



I have changed nothing on my end, but I gave it a try again today and so far it has been working. Keeping my fingers crossed.

Can any one help out for this issue because suddenly this error occured,


Console warning => Library is not coming from Accept server.


After submit the form with valid credit card details,

Response =>  Accept.js is not loaded correctly.

Code => E_WC_03


I didn't changed my code for past 2 weeks it was working before 1 week but not now.


I had tried all the solutions mentioned in forum like clearing borwser cache,  tried in incognito mode, also with different browsers like firefox, chrome, IE, edge all returns the same error.


Please give me some perfect solution, already wasted more than 2 weeks with this issue. Reply ASAP