Showing results for 
Search instead for 
Did you mean: 

CIM - ASP/VBScript - Sudden E000001 with no change to Util.asp

It's probably just late and so I'm not seeing something, but the code that generates my XML statement didn't change and the util.asp file with the send command didn't change, nothing on my server changed, but I'm suddenly getting an error. (Obviously, something must have changed somehow, because it's not working. lol):


Here's what the feedback looks like:




Raw request:
<?xml version="1.0" encoding="utf-8"?>
<createCustomerProfileRequest xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd">

Raw response:
<?xml version="1.0" encoding="utf-8"?>
<createCustomerProfileResponse xmlns:xsi="" xmlns:xsd="" xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd">
An error occurred during processing. Please try again.
<customerPaymentProfileIdList />
<customerShippingAddressIdList />
<validationDirectResponseList />




It takes a long time to get the error back - feels like a time out, almost. I rebooted my server, and it didn't help.


Earlier today in another part of the system (the part that retrieves a list of customer credit cards) I suddenly started getting the error "The download of the specified resource has failed", and again, it with no changes to the code. Seriously - one second it loaded fine, the next second it did not. I fixed that with a suggestion from a post here (change Set objHTTP = Server.CreateObject("MSXML2.ServerXMLHTTP")" to
Set objHTTP = Server.CreateObject("Microsoft.XMLHTTP")...included that here in case someone is searching for that error), but that didn't work for this other problem.


I'm lost.


It must be something obvious, but I'm just not seeing it.


Any clues?


Thanks so much,




Accepted Solutions

I have automated tests that once passed, and now fail, with no changes.  So I can almost guarantee its not you.

View solution in original post


More information:


I had tried about everything...I normally work on a password protected development site, so I moved it over to live website to see if that would help. Live has a server certificate, and I tried both HTTP and HTTPS, and nothing helped.


I created a stripped down file with just the call to, grabbed just the 2 routines I needed from util.asp (sendAPIRequest and MerchantAuthentication), so the file was as small as possible and still got the error.


Finally, I switched to instead of with the appropriate login information, and it worked quickly and perfectly.


So I edited the original files (the full page and the utlity file) to use the again, it worked perfectly.


For testing I desperately need to use the test account.


Any ideas?







I am seeing a similar issue (error E00001 returning after about 30 seconds), so I suspect an issue with the test server.

Boy if one more person could confirm that, I'd go to bed. lol. It's 3:30AM here, and I've been beating on this for hours now.



I have automated tests that once passed, and now fail, with no changes.  So I can almost guarantee its not you.

You're my hero. It's bedtime. :)

And if you need any more confirmation, try creating a CIM payment profile via the UI at  It doesn't work there either.

@Julie, tech team is aware of this issue.  Follow results over here:

Hey everyone,


It's true...we're having issues with CIM on the test server. Once we know more on when it will be fixed, we'll update this post. Sorry for the problems!! :smileysad:





Developer Community Manager

I'm getting this problem too. And, I can't create one on the website either. Are there any problems?