Showing results for 
Search instead for 
Did you mean: 

Error 57 Giving me trouble

I am using uniCenta, an open source solution, that integrated your JAVA SDK.  The oPOS has some 13000 users and I find it hard to believe that I am the first to use Authorize.Net  I searched the forums and did not find uniCenta mentioned.


When I run the software in Test mode with a developer API ID etc, I receive an email with: Response : This transaction approved.


When I run the software in Live mode with a real API ID and tranaction key I get error 57 Error during processing transaction. This error code is shown inside the software.



I am aware that code 57 suggests that some field is left blank. (Which ones?)

I am aware that code 57 is sent to Lightspeed POS when they have the x_market_type set wrong. (How do I find that?)
I am aware that the message suggest to contact the merchant service provide - and we have. 


An Auth.Net tech support agent also run a test from within your virtual terminal and the transaction was apporpriately declined suggesting that your settings match the merchant service provider. 


So all that said, it seems to point the POS software.


However, when I look at the transaction detail provided when logged in as a merchant, I do not see any missing fields.  Obviously I can not see all the required fields in that table as required in the Min Field list.


Below is a transaction with the error.  Can someone look at tranaction data stream and tell me what is going on?


Transaction ID: 4122569184
Transaction Status: General Error  (Processor error - An error occurred during authorization. If these errors persist, contact merchant service provider)
Settlement Information
Settlement Amount:USD 2.38
Settlement Date and Time:20-Jan-2012 17:27:23
Business Day:20-Jan-2012
Batch ID:179178369

Hello grif,


With the errors you are receiving, the likely cause is a problem in the configuration with your processor.  Only customer support can verify this information and run test transactions for your production account.  You are welcome to ask for advanced support agents since you spoke with someone already.



Long time coming. Now fixed.


You can pick up latest version 3.55 go to