cancel
Showing results for 
Search instead for 
Did you mean: 

SIM Relay Response Timeout

I am encoutering an issue in which a user receives a timeout error about 1 out of 10 transactions.   The response form only returns a simple html page with success or failure message.  There are no links to javacsript/css/images in the response page.   I checked the server logs and there isn't any record in the apache logs of an attempted post request.   I have tried processing credit card transactions myself on the live site and get a response from 1-2 seconds.

 

I looked through knowledge base and made some changes based on suggestions but still receiving the occasional timeout error.

 

Any suggestion?  Maybe Apache/PHP post settings for faster response?

 

Thanks,

 

Pat

 

pat1234
Member
74 REPLIES 74

Given that Authorize.net works for most people just fine, the lag looking up the domain is likely caused by something on your end, possibly slow nameservers and/or intermittent hosting lag. What hoster are you using, and is it shared hosting or virtual dedicated or what?

I'm getting this issue as well. I double and triple checked my Relay Reponse URLs, but after Sumitting the transaciton, I don't even see an incoming post in our Apache logs.

 

I've seen in other threads that Authorize.NET could be rejecting my SSL cert. I tried submitting the request without the cert, using http, and it did not throw the timeout error. I actually can't get it to throw the timeout error on http. On https, it always throws the error.

 

Is there a solution for this?

ACuffman
Member

It could be your cert, where did you get it?

I've tried several pages. They all seem to work fine as long as my Reponse Relay isn't using my cert. Otherwise, it always throws the "script timeout" error.

 

This is the first problem I've had with this cert. Are there any previous user problems that are similiar.