Showing results for 
Search instead for 
Did you mean: 

x_relay_url error


I hope you can help.


We have a ticketing (theatre) system, which we are testing with a live account (test mode ON). All is well except when the customer is redirected back to browser we get 

"The reporting of this transaction to the Merchant has timed out. An e-mail has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card. This transaction has been approved. It is advisable for you to contact the merchant to verify that you will receive the product or service." Also on the email from we get this:


Authorize.Net Merchant,


Your script timed out while we were trying to post transaction results to it.

Transaction ID: 0

Transaction Result: This transaction has been approved.


We did read the literature on this from authorize, and this is where we are:

If we eliminate x_relay_url from our server then all is well. We get the invoice from Authorize (we use SIM-we cannot implemet yet the newest API) and we are happy with that.


BUT then the customer does not receive the confirmed email which contains the link to download a PDF of his/her tickets. Thus no matter what, we have to have the x_relay_url which is this

[our url]/index.php?controller=pjFront&action=pjActionConfirmAuthorize

Also, this script can be ran after payment confirmation, so to run it "cold" does not do much.

Any ideas, maybe some clever redirection after this x_relay_url? We tried many possible combinations on relay - with the exact url, without, a thank you page url - but we keep on getting the same message.


Thank you.



Hello @costa


We don't recommend using a production endpoint in Test Mode for testing.  When you do, the gateway only checks the API Login and Transaction Key are valid and returns success or failure.  Instead, we recommend using a free sandbox account.


Also, because you're using test mode, no transaction was attempted ( which is confirmed by the transaction id of Zero.


And finally, the error indicates that our server is unable to POST to the relay URL you supplied.  It must be on a publicly available IP address and on port 80 or 443.



Administrator Administrator

Thank you.

But I thought transactions were attempted and resolved as I received emails as merchant and seller and payment confirmation..

Also, I started with sandbox and tested before i purchase a real account and was told by tech because I did not have a live account the testing would not be accurate just like you are saying. But you are telling me the opposite! So I have now a live account which is on test mode, but our system is not on test mode as in order to work on test mode I would need to go back to sandbox.


But I shall do that and follow  your advice. I will go back to my sandbox account and retest.


Thank you again.

We finished testing in sandbox. The error remains the same. We tried a few different url, etc. but the behaviour is excatly the same.


If you have any other suggestions, please let me know.



My apologies for any confusion regarding testing in sandbox and production. 


When you tested in the sandbox, did you also get a transaction ID of zero or was a value returned?  Were you able to see the transaction in the sandbox merchant interface at


If you you can provide the full relay_response URL you are attempting, we can determine if we're able to successfully connect.



Thank you for your prompt reply. 

In sandbox the email is the same with id=0

I checked in the interface under transaction search and there is nothing. I di dnot know that we would see anything in sandbox mode.

Do you have private section to send the url? If I ran it it does not do much as it needs to be validated by a confirmed payment. Then it sends a success email to the client.


In the production test mode we checked there also and there is no record of any transaction. We did test  also without any x_relay_url and authorized showed the invoice at the end. Again, are we suppose to see transactions in transaction search during test mode?

Thank you.




You can send me a private message the your details. 


Because your sandbox transactions also had a transaction id of zero, you must either have set your sandbox to test mode or you included testmode=true in your transaction request.  Please try again with test mode turned off.





Thank you again.


The sandbox was pointing at the production url as when it is on false thats what it does.  I replaced the url with the sandbox and please see id below.


Your script timed out while we were trying to post transaction results to it.

Transaction ID: 60040510037

Transaction Result: This transaction has been approved.


The following message was displayed to the customer:


------------------------------An error occurred while trying to report this transaction to the merchant........


It is now a "captured/pending settlement".

That is progress.


Forgive me, I must be blind. How do I send a private message?



@costa click on the email icon near the top right of the community.



Two immediate suggestions: 


  1. Make certain your sandbox is runng live mode
  2. URL-encode your Relay URLs, as this may help with certain characters being stripped.

Also, I should remind you that SIM is now deprecated.  We encourage you to begin migration to one of our newer solutions using an Accept module and Webhooks.