Showing results for 
Search instead for 
Did you mean: 

Response returning empty

We were using PHP SDK from

It was working but then suddenly stop working. Our issue is that the response is returning empty. Any ideas?


Having a similar issue haven't solved it, but check your authorize log file.  It may have more info. 


Where can I find the authorize log file?

You would need to set it before the authorize autoload.php file is included. 


Set it by putting this: define("AUTHORIZENET_LOG_FILE",  "/path/to/log_file_here");

Getting the same problem here since Friday as well. log message is:

SSL certificate problem: unable to get local issuer certificate


I have tried to update ./lib/ssl/cert.pem from the GitHub project, as well as trying the big one from, neither one seems to work. I tried setting $VERIFY_PEER to false as well, but that apparently just shuts the whole connection down entirely. If I modify ./lib/shared/AuthorizeNetRequest.php to actually set CURLOPT_SSL_VERIFYPEER to false here, it does go through successfully. Obviously modifying the vendor code, and disabling the SSL verification, won't be ideal in the long term... likely fine in localhost/sandbox only, but I wouldn't want either one of those things in production.

I'm receiving this error....


SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

It seems the issue is that cert.pem is a sha1 certificate 

I put the system in live mode and it seems to be working.....

I have also same facing , please give me any idea how can resolve it.


If the issue is with .pem file is sha 1, then .pem file having sha 2 may resolve the issue. Anybody know how to create one?