Showing results for 
Search instead for 
Did you mean: 

Production Certificate Upgrades begin May 26, 2015

Authorize.Net will upgrade and replace Production certificates for API services starting May 26, 2015. Technical details are provided for solutions connecting to Authorize.Net APIs that may need updates.


To see the full announcement, please see this blog post.

Administrator Administrator
172 REPLIES 172

People on this bulletin board began posting HELP!! messages a few hours after the switch.
Some of these messages have about 500 views.
I posted a note about fixing a CENTOS server 48 hours after the switch. That had 45 views in 30 minutes.

What does that tell you,
500 FAILED CUSTOMERS who happen to have enough geekiness to be looking for answers on an obscurely linked bulletin board.

45 CUSTOMERS still prowling the board, 48 hours later.

I would bet that the viewers of this board have 2 things in common:
Enough geek smarts to know to look for answers on a forum.
A business active enough so that a lack of transactions causes a bell to go off.

I would guess that the viewers of this forum represent a VERY SMALL FRACTiON of your merchant customer base.
The merchants I have brought to authnet would NOT be looking at this board.

Which suggests to me quite strongly
YOU HAVE CAUSED THOUSANDS OF MERCHANTS TO FAIL with this ill-considered upgrade method.


Hi all,


My client's servers are still down and losing business by the hour.


Has anyone been able to get this working on a Rails / nginx stack on Ubuntu?


Per nginx' configuration docs ( I've added all prescribed parameters including the ssl_certificate and ssl_certificate key.


The cert was originally issued by Godaddy. I've tried appending the certs from the php sdk ( in many ways with no success.


The present order, which does not work, is as follows:



...Original GoDaddy issued cert...


...First GoDaddy intermediate cert...

...Second GoDaddy intermediate cert...

------BEGIN CERTIFICATE------ issued cert 1 from php sdk...

------BEGIN CERTIFICATE------ issued cert 2 from php sdk...

------BEGIN CERTIFICATE------ issued cert 3 from php sdk...

------BEGIN CERTIFICATE------ issued cert 4 from php sdk...


I've also gone so far as removing the GoDaddy intermediate certs entirely with no luck.


Hoping someone can give me some pointers to get me back on track


Just for anyone who is still fighting with this.....


After a lot of emails and phone calls with my website hosting company, it was determined that the server my site was on was running an outdated operating system.  Website was migrated to a newer server and everything works now.  


It turned out to be a pretty easy fix, but took three days to figure out the solution.  Ugh.


So if you're a website owner, but not the hosting company or developer - contact your hosting company and ask about the server your site is hosted on.    

I finally got mine working with WIndows 2008 and PHP. I had the 5 certificates installed but I wasn't using the latest version of the PHP API at


I also had to make a couple of code changes but was able to work it all out using the examples in the API tests. If anyone has the same set up and needs help ping me



I have the same issue as most others.  I rent a virtual server at GoDaddy, which is SSL/Apache based and I run PHP on my website and use CURL code to run transactions via  Since the upgrade, I can't process credit cards on my site.  I've upgraded to SHA-2 SSL and still no connection.  I'm not familiar with how to install root certificates on my server to fix this issue.  If anyone can help me, I would appreciate it, and of course pay for time spent getting my site to process credit cards again.  I've used since 2004 and this is the first time I've been shut out without real warning.  I'm upset about it, just like the rest of you. 


Please ping me if you can help.  Thanks. proved to be a mom and pop shop and does not have the know how to transition its systems seamlessly. 

pcg, thank you for the response.


I was curious if you made any progress since Friday morning? Were you able to get it to work with a cfexecute + cURL solution?


Can you process transactions yet?

One of our two customers is up and running after apply patches to their Windows 2003 server. They were years behind on updates. Still working on the second one.

@gh Your Ubuntu/Rails/ActiveMerchant post was *extremely* helpful. It ended days of blind troubleshooting. I can't thank you enough.

Didn't see @gh's poist previously, thanks for that. Didn't end up solving our problem, but may be able to help other folks on an Ubuntu / Rails stack, so truly valuable.


Our solution was - basically upgrading activemerchant / symlinking in cacert.pem on our production server.


Hopefully this helps others.


Extremely bad form, -- I know my client won't be the first to treat this mishap as motivation to switch to another payment gateway.